Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/248961

From BetaArchive Wiki
Knowledge Base


Article ID: 248961

Article Last Modified on 11/25/2002



APPLIES TO

  • Microsoft Access 2000 Standard Edition



This article was previously published under Q248961

Advanced: Requires expert coding, interoperability, and multiuser skills.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).


SYMPTOMS

When you compile a Microsoft Access 2000 database or project, all empty event procedures are removed from the form and report modules in your database. However, when you close the database, you only get a prompt to save one form or report, even if you have modified more than one form or report module.

RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:

245025 OFF2000: How to Obtain and Install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Create a new Microsoft Access 2000 database.
  2. Create a new form, and name it Form1.
  3. In Design view of the Form1 form, click Properties on the View menu, and then set the OnLoad property to [Event Procedure].
  4. Click the Build button to open the Visual Basic Editor. Note the empty Form_Load event procedure.
  5. Close the Visual Basic Editor, and then save and close the Form1 form.
  6. Make a copy of the Form1 form, and name it Form2.
  7. Open the Visual Basic Editor (ALT + F11), and then click Compile on the Debug menu.
  8. Close the Visual Basic Editor, and view the items on the Window menu. Note that the Form1 form and the Form2 form are open.
  9. Click Close on the File menu. Note that you get a message that asks you if you want to save the Form1 form. However, the empty procedures in both of your forms were removed during the compile.



Additional query words: pra

Keywords: kbbug kbfix KB248961