Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/105765

From BetaArchive Wiki

Macros in the CONVERT, LAYOUT, TABLES, and MACRO60 Templates

Q105765



The information in this article applies to:


  • Microsoft Word for Windows, versions 6.0, 6.0a
  • Microsoft Windows 3.1





SUMMARY

After running a Complete installation of Word for Windows, the following templates are copied to a MACROS subdirectory in the Word 6.0 program directory (for example, C:\<WINWORD6\MACROS).

CONVERT.DOT

MACRO60.DOT
TABLES.DOT

LAYOUT.DOT

This article contains a list of the macros in each of these templates, including notes about their limitations or any problems.

Note: The Typical Setup option does not install the above templates to the MACROS subdirectory.

The CONVERT.DOT template contains the following useful macros to simplify converting and changing conversion options:

   Macro                       Explanation and Notes
   -------------------------------------------------------------------
   BatchConverter              Runs a wizard that helps you select and
                               convert multiple files from another
                               format to Word or vise versa.

   EditConversionOptions       Opens a dialog box that allows you to
                               customize file conversion settings. The
                               macro changes the conversion options by
                               changing the settings in the MSTXTCNV.INI
                               file.

   PresentIt                   Converts a Word document into a Microsoft
                               PowerPoint presentation. 

The MACRO60.DOT template contains the following useful macros you can use in your general work with Word for Windows:

   Macro                       Explanation and Notes
   -------------------------------------------------------------------

   DisableAutoBackup           Disables the Enable/Disable Auto Backup
                               command on the File menu (added by the
                               EnableAutoBackup macro) and removes the
                               FileSave and FileSaveAs macros.

   EnableAutoBackup            Adds the Enable/Disable Auto Backup command
                               to the File menu. It also creates FileSave
                               and FileSaveAs macros that create backups
                               when you save files. The macro prompts you
                               for a location to save the backups.

   ExitAll                     Closes all open document, template, and
                               macro-editing windows. A dialog box lists
                               all open documents and prompts you to save
                               them.

   FindSymbol                  Finds and replaces symbols inserted with
                               the Symbol command (Insert menu). In the
                               Find And Replace Symbols dialog box, choose
                               the Find What button to select the symbol to
                               search for; choose the Replace With button
                               to select the symbol to replace it with.

   FontSampleGenerator         Generates a sample document that you can
                               print out to show all printable fonts on
                               your system in the point size you specify.

   MindBender                  Demonstrates through a sample game several
                               methods for using dynamic dialog boxes.

   OrganizationalChartMaker    Builds an organizational chart using the
                               drawing tools in Word. Set up the hierarchy
                               using built-in heading styles (do not
                               include any tab characters) and run the
                               macro.

   PrnSel2File                 Saves selected text in an MS-DOS text file.
                               Select the text and run the macro. You can
                               append to or overwrite an existing file or
                               create a new one.

   RunWizard                   Displays a dialog box of available wizards
                               that you can run.

   SetPrintFlags               A Product Support Services support macro.
                               Modifies advanced printing behavior. Use
                               with caution.

   SuperDocStatistics          Displays a dialog box with a comprehensive
                               list of the open document's statistics. For
                               example, all fonts used in the document are
                               listed. 

Note: The Macro60 toolbar contains a DateCalculations button, but MACRO60.DOT contains no DateCalculations macro. Microsoft removed the DateCalculations macro prior to shipping Word but did not also remove the DateCalculations button from the Macro60 toolbar.

The TABLES.DOT template contains the following useful macros you can use when working with tables:

   Macro                       Explanation and Notes
   -------------------------------------------------------------------

   AccessExporter              Converts a selected Word table into an
                               Access table.

   TableFillDown               Fills cells in the selected table column
                               with the top-most value of each column.
                               Select the columns you want to fill and
                               run the macro.

                               Warning: Overwrites existing cell contents.

   TableFillRight              Fills cells in the selected table row

                               with the left-most value of each row.
                               Select the rows you want to fill and run
                               the macro.

                               Warning: Overwrites existing cell contents.

   TableMath                   Helps you insert formula fields into a
                               table by selecting cell references and
                               calculation types such as sum, average,
                               and count. Position the insertion point
                               in the table and run the macro.

                               For more information about the TableMath
                               macro, query on the following words in
                               the Microsoft Knowledge Base:

                                  tablemath and tables.dot and

   TableNumber                 Adds numbering to rows or columns. If
                               necessary, a row or column is added to
                               contain the numbering. Position the
                               insertion point in the table, start the
                               macro, and select the numbering option
                               you want from the dialog box. 

The LAYOUT.DOT template contains the following useful macros you can use to manipulate text and page layouts.

   Macro                       Explanation and Notes
   -------------------------------------------------------------------
   ArrangeWindows              Displays a dialog box where you can choose
                               to arrange all open windows tiled,
                               horizontally, vertically, or cascaded.

   BaseShiftDown               Lowers selected text by one point. To lower
                               the text further, run the macro again.

   BaseShiftUp                 Raises selected text by one half point. To
                               raise the text further, run the macro again.

   Cascade                     Rearranges all open windows so they overlap
                               in a cascade.

   CharacterTrackIn            Condenses the spacing of a selection by
                               fractions of the font size. To condense the
                               text further, run the macro again.

   CharacterTrackOut           Expands the spacing of a selection by
                               fractions of the font size. To condense the
                               text further, run the macro again.

   DecreaseFont                Reduces the font size of a selection by one
                               point. To reduce the font size further, run
                               the macro again.

   DecreaseLeftAndRightIndent  Decreases the indent for the selected
                               paragraphs an equal amount towards the left
                               and right margins using the default tab
                               settings.

   IncreaseFont                Increases the font size of a selection by
                               one point. To increase the font size
                               further, run the macro again.

   IncreaseLeftAndRightIndent  Indents selected paragraphs an equal amount
                               from the left and right margins using the
                               default tab settings.

   LineSpaceIn                 Decreases line spacing for the selected
                               paragraph or paragraphs.

   LineSpaceOut                Increases line spacing for the selected
                               paragraph or paragraphs.

   Overscore                   Adds an overscore to selected text by
                               replacing the text with an EQ (Equation)
                               field.

                               Limitations:

                               1. "Selection is invalid" error
                                  when text includes a paragraph mark or
                                  when text wraps to a second line.

                               2. After running Overscore macro, Undo
                                  is unavailable. To undo, copy text
                                  from EQ field.

   PrintableCharacters         Creates a document containing all printable
                               characters for a font. When you run the
                               macro, a custom font dialog box is
                               displayed so you can choose the font.

   SectionManager              Displays all section-level formatting in
                               one dialog box. You can also modify section
                               formatting using the Page Setup, Page
                               Numbers, and Columns buttons.

   TileHorizontally            Tiles all open documents horizontally.

   TileVertically              Tiles all open documents vertically. 

Additional query words: 6.0 tables layout convert word6 tables.dot layout.dot convert.dot macro6.dot orgchart ansivalue overbar overstrike winword

Keywords :
Issue type :
Technology :


Last Reviewed: November 4, 2000
© 2001 Microsoft Corporation. All rights reserved. Terms of Use.