Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/103795

From BetaArchive Wiki

Mac Works: Import/Export Database to Mac FoxBase Plus

PSS ID Number: Q103795 Article last modified on 10-22-1998

2.0 3.0 4.0

MACINTOSH

======================================================================

The information in this article applies to:

  • == Microsoft Works for the Macintosh, versions 2.0, 3.0 and 4.0 ==

SUMMARY

To export Microsoft Works 2.0 and 3.0 Database files to FoxBase Plus for the Macintosh, first save the document to a text file, then import the file into FoxBase Plus.

Exporting from Works 3.0

To export Database files from Works 3.0 or 4.0 to a text file, do the following:

  1. Open the Database file in Works 3.0 or 4.0.
  2. From the File menu, choose Save As.
  3. Rename the file, choose File Format and select Text.
  4. Choose Save.

Exporting from Works 2.0

To export Database files from Works 2.0 to a text file, do the following:

  1. Open the Database file in Works 2.0.
  2. From the File menu, choose Save As.
  3. Rename the file and select Export File.
  4. Choose Save.

Importing Database Files into FoxBase Plus

To import Database files into FoxBase Plus, do the following:

  1. Create new database headings in FoxBase Plus by choosing File from the New menu, selecting Database and Inserting field names.
  2. Give the FoxBase Plus database a new name, select a folder to save it into, and click Input Data Records Now Yes.
  3. Under the Database, select Append From.
  4. Click All Files, select the Works database and click From.
  5. The File Type selection should be Delimited With Tabs.
  6. Click Append.

Importing Files from FoxBase Plus to Works

To import files from FoxBase Plus to Works, first export the file to a text file, then import the file into Works.

To export the Database to a tab delimited text file, do the following:

  1. Open the Database in FoxBase Plus.
  2. From the Database Menu, select Copy To.
  3. Type a name and location of the new exported database.
  4. In the File Type box, select Delimited By Tabs.
  5. Click OK.

To import the database to Works 3.0 or 4.0, do the following:

  1. Open Works by double-clicking the icon.
  2. Click once on the database icon.
  3. Locate the database on the hard drive, using the scroll bar.
  4. Click Open, or double-click the database name.
  5. Works will prompt you with the Separate Database Fields By dialog box. Select Tabs and choose OK.

To import the database to Works 2.0, do the following:

  1. Open Works by double-clicking the icon.
  2. Click the Database icon.
  3. Click Import File to select the file.
  4. Locate the database on the hard drive using the scroll bar.
  5. Click Open, or double-click the database name.
  6. Works will prompt you with the Separate Database Fields By dialog box. Select Tabs and choose OK.

MORE INFORMATION

For more information, see pages 433-436 of the “Microsoft Works User’s Guide,” for version 3.0 and pages 397-408 of the version 2.0 “Microsoft Works User’s Guide.” Also see pages A-2, 8-10, and 8-13 of the “FoxBase+ User’s Guide.”

KBCategory: kbother KBSubcategory: macworkskb

Additional reference words: 2.00 3.00 mac mwksdb import export Foxbase AFE

====================================================================== Version : 2.0 3.0 4.0 Platform : MACINTOSH Issue type : kbhowto ============================================================================= Copyright Microsoft Corporation 1998.