Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/102149

From BetaArchive Wiki

Article ID: 102149

Article Last Modified on 10/23/2003



APPLIES TO

  • Microsoft CodeView 4.0
  • Microsoft CodeView 4.01
  • Microsoft CodeView 4.01
  • Microsoft CodeView 4.1
  • Microsoft CodeView 4.0
  • Microsoft CodeView 4.01
  • Microsoft CodeView 4.1



This article was previously published under Q102149

The text below lists the function keys the Microsoft CodeView debugger uses.

Moving with the Keyboard

   Action                                  Key Combination
   -------------------------------------------------------------------
   Move cursor up, down, left, right       UP ARROW, DOWN ARROW,
           LEFT ARROW, RIGHT ARROW

   Move cursor by words left and right     CTRL+LEFT, CTRL+RIGHT
   Move cursor to beginning of line        HOME
   Move cursor to end of line              END

   Page up and down                        PAGE UP, PAGE DOWN
   Page left and right                     CTRL+PAGE UP,
                                             CTRL+PAGE DOWN

   Move cursor to beginning of window      CTRL+HOME
   Move cursor to end of window            CTRL+END
   Move to next window                     F6
   Move to previous window                 SHIFT+F6
   Restore window                          CTRL+F5
   Move window                             CTRL+F7
   Size window                             CTRL+F8
   Minimize window                         CTRL+F9
   Maximize window                         CTRL+F10
   Close window                            CTRL+F4
   Tile windows                            SHIFT+F5
   Change to mixed source/assembly mode    F3
   Set a breakpoint at the location        F9

   Active Window  Action
   -------------------------------------------------------------------
   Locals         Displays Locals     Window Options   CTRL+O
   Source 1       Displays Source 1   Window Options   CTRL+O
   Source 2       Displays Source 2   Window Options   CTRL+O
   Memory 1       Displays Memory 1   Window Options   CTRL+O
   Memory 2       Displays Memory 2   Window Options   CTRL+O
        

Using the File Menu with the Keyboard

   Exit to the system prompt               ALT+F4
        

Using the Edit Menu with the Keyboard

   Undo                                    ALT+BACKSPACE
   Copy                                    CTRL+INS
   Paste                                   SHIFT+INS
        

Using the Search Menu with the Keyboard

   Find                                    CTRL+F
   Selected Text                           CTRL+\ 
   Repeat Last Find (CodeView for MS-DOS)  ALT+/ 
   Repeat Last Find (CodeView for Windows) CTRL+R
   Repeat Last Find (CodeView for Win32s)  CTRL+R
        

Using the Run menu with the Keyboard

   Go                                      F5
   Step                                    F10
   Trace                                   F8
   Go to Cursor                            F7
   Stop after Return                       SHIFT+F7
        

Using the Data Menu with the Keyboard

   Add watch...                            CTRL+W
   Delete Watch...                         CTRL+U
   Quick Watch...                          SHIFT+F9
   Breakpoints...                          CTRL+B
        

Using the Options Menu with the Keyboard

   Open Memory window option dialog box    CTRL+O
   Cycle through the display formats       SHIFT+F3
   Cycle through the display formats       CTRL+SHIFT+F3
in reverse order
        

Using the Windows Menu with the Keyboard

   Restore the active window to its size   CTRL+F5
     and position before it was maximized
 
   Move the active window                  CTRL+F7
   Size the active window                  CTRL+F8
   Minimize the active window              CTRL+F9
   Maximize the active window              CTRL+F10
   Close                                   CTRL+F4
   Tile                                    SHIFT+F5
   Arrange all open windows                ALT+F5
   Open the Help window                    ALT+0
   Open the Local window                   ALT+1
   Open the Watch window                   ALT+2
   Open Source window 1                    ALT+3
   Open Source window 2                    ALT+4
   Open Memory window 1                    ALT+5
   Open Memory window 2                    ALT+6
   Open Register window                    ALT+7
   Toggle Register window on/off           F2
   Open 8087 window                        ALT+8
   Open the Command window                 ALT+9
   Swap to program's output screen         F4
        

Using the Help Menu with the Keyboard

   Contents                                SHIFT+F1
   Topic                                   F1
        


Additional query words: kbinf 4.00 4.10

Keywords: kbbug kb16bitonly kbdebug KB102149