Longhorn 4074 stuck on WinPE + ImageX doesn't work

Discuss Windows Vista/Server 2008 to Windows 10.
Post Reply
ActivateYourTech
User avatar
Posts: 187
Joined: Tue Jun 08, 2021 1:43 pm

Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by ActivateYourTech »

Hi y'all,

Recently I have been experimenting with Windows Longhorn build 4074 on real hardware. The specs are as follows:
i5-3350P @3.10GHz
4GB DDR3 RAM
1TB Seagate HDD
AFOX GT-710 GPU
ASRock H61M-VG3 Motherboard

So anyways, I first tried to burn 4074 on a CD. It worked fine (I tested it by installing 4074 on a VM with the burnt CD), but Windows got stuck on the "Starting Windows Preinstallation Environment" screen. I then proceeded to use ImageX from WAIK Vista RTM, but it gave error 11 (failed to read wim header, then it said "An attempt was made to load a program with an incorrect format"). That being said, it did say that it would not work with pre-Beta 2 files.

Then, I used XImage. I originally had trouble finding it, but with some trying found it. XImage for 4059 and 4007 said "The specified module could not be found", but XImage from 5112 complained about it being unable to find or load XMLRW.dll.

DISM also had trouble applying and getting info from the WIM of 4074, and I then tried DISM and XImage for 4001, 4005, and 5048, but they didn't work.
I did, however, see a comment about Longhorn's WinPE not working on certain motherboards, but I don't know why XImage didn't work.

Is there a reason for this?

Thanks
https://www.youtube.com/@techactivate781
I don't like Windows 10/11. I like (best to 4th best): 7, 8.1, Vista, and XP.
Cars I like: Toyota Corolla, Hyundai Aura, Tata Tiago, Suzuki Dzire, and Suzuki Ciaz
New Zealand should win the T20 wc this year! (sad after 2019...)

dixieLH
User avatar
Posts: 369
Joined: Mon Apr 12, 2021 8:59 pm

Re: Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by dixieLH »

the very 1st sentence makes no sense
you say you burned iso to CD and it "worked fine" in VM "but windows got stuck on starting PE"

how is this fine ? -_-

ActivateYourTech
User avatar
Posts: 187
Joined: Tue Jun 08, 2021 1:43 pm

Re: Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by ActivateYourTech »

Sorry about that, I meant that 4074 installed from the CD in the VM, but on the PC it got stuck on starting Windows PE
I also tried this https://longhorn.ms/boot-from-usb/, but it did not work
Then I used a WIM-based installation of 3718, but that got stuck on the boot screen

Edit: I used the ximage in PantherXP to apply Windows Longhorn build 4074. Index 1 and 2 said "NTLDR is missing", but Index 3 (which seemed to contain the Windows installation), got stuck on a black screen. I also tried to install 4074 on a VM, then apply the VHD to the HDD, but it was on a black screen
https://www.youtube.com/@techactivate781
I don't like Windows 10/11. I like (best to 4th best): 7, 8.1, Vista, and XP.
Cars I like: Toyota Corolla, Hyundai Aura, Tata Tiago, Suzuki Dzire, and Suzuki Ciaz
New Zealand should win the T20 wc this year! (sad after 2019...)

dixieLH
User avatar
Posts: 369
Joined: Mon Apr 12, 2021 8:59 pm

Re: Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by dixieLH »

well maybe you just can't expect with newer hardware to accept Longhorn anymore...
always target year 2002 - 2005 ?
i mean even your GPU won't work on it
these are still XP drivers in question

ActivateYourTech
User avatar
Posts: 187
Joined: Tue Jun 08, 2021 1:43 pm

Re: Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by ActivateYourTech »

Shouldn't it support LH if it supports XP?
https://www.youtube.com/@techactivate781
I don't like Windows 10/11. I like (best to 4th best): 7, 8.1, Vista, and XP.
Cars I like: Toyota Corolla, Hyundai Aura, Tata Tiago, Suzuki Dzire, and Suzuki Ciaz
New Zealand should win the T20 wc this year! (sad after 2019...)

dixieLH
User avatar
Posts: 369
Joined: Mon Apr 12, 2021 8:59 pm

Re: Longhorn 4074 stuck on WinPE + ImageX doesn't work

Post by dixieLH »

depends per driver :P
your card is from late 2016, quite staggering that XP supports it :|

Post Reply