OS/2 1.0 PIGSKIN fails to boot

Discussions about *nix and Other Operating Systems should go in this forum.
Post Reply
FTP Access
Posts: 196
Joined: Sun Apr 28, 2019 10:11 am

OS/2 1.0 PIGSKIN fails to boot

Post by vlad557776 »


Recently I've managed to get my hands on a working build of 86box with serial passthrough support and tried to boot the PIGSKIN OS/2 beta on multiple machines, all of which failed.

All the 286es I've tried hang before the System Debugger is even fully initialized, plus it's pretty useless to emulate a 286 in this case as I'd want to test the real mode application multitasking capabilities.

Most 386es I've tried crash after enabling paging at a GPF trap 13 in different places depending on the machine and the configuration, the farthest I've gotten was an IBM PS/2 Model 55SX which actually printed the bootscreen messages but then crashed with a "User Error 0900:1901 Invalid segment register value or cannot reload user segment" which according to OS/2 Museum means that I have an incompatible CPU (even though the VM is configured to use an Intel 386SX, something that should work).

Is there a 86box config which can actually boot this build provided a debugger on COM2 which I have?

Thanks in advance.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

User avatar
Posts: 3591
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy

Re: OS/2 1.0 PIGSKIN fails to boot

Post by TheCollector1988 »

You could try a 386DX machine.

User avatar
FTP Access
Posts: 215
Joined: Wed Nov 22, 2017 5:39 pm

Re: OS/2 1.0 PIGSKIN fails to boot

Post by BF10 »

If this is the revision 4.41 build, it's not possible to boot under normal circumstances from what I have tested. I have also tried to use PCjs's debugger for that build on various machines and it would refuse to get past the boot screen as it drops to the debugger then it crashes if you try to boot again.

For the other builds, I've been simply able to get them to properly boot on PCjs.

BetaWiki contributor.

Post Reply