BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 9d, 5h, 58m | CPU: 51% | MEM: 5227MB of 11353MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 14 posts ] 
Author Message
 PostPost subject: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 8:10 am 
Reply with quote
User avatar
Offline

Joined
Sun Jul 22, 2018 11:16 pm

Posts
15

Location
Nebraska

Favourite OS
Windows Server 2003 Itanium
I've been trying to run the OG Home Server as a virtual machine under Server 2012 R2 and it's not playing nicely. Under the built-in HyperV it gave me an error stating that "Home Server requires at least 60GB of space" and just refused to install.

I've tried adjusting the virtual hard drive up to 1TB but it still gives me the same message. I've tried dedicating an entire hard drive to the VM and nothing.

Am I missing something here or should I try VMware?

((No wonder I hate Vista..it has the same vibe during setup and it just urked me right then and there :mrgreen:))

_________________
When in doubt, Windows XP it out!


Top  Profile
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 11:54 am 
Reply with quote
User avatar
Offline

Joined
Wed Apr 17, 2019 12:44 pm

Posts
133

Location
C:\winnt\system32\ntoskrnl.exe

Favourite OS
All windows versions before 10
Try VMware or VirtualBox

_________________
Image
i am proto
your security is my motto


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 3:54 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Feb 25, 2018 6:49 pm

Posts
233

Location
GMT+2 w/dst

Favourite OS
5xxx series (Vista)
ItaniumCommando wrote:
I've been trying to run the OG Home Server as a virtual machine under Server 2012 R2 and it's not playing nicely. Under the built-in HyperV it gave me an error stating that "Home Server requires at least 60GB of space" and just refused to install.

I've tried adjusting the virtual hard drive up to 1TB but it still gives me the same message. I've tried dedicating an entire hard drive to the VM and nothing.

Am I missing something here or should I try VMware?

((No wonder I hate Vista..it has the same vibe during setup and it just urked me right then and there :mrgreen:))

Try using a fixed VHD being at least 100-200GB.

_________________
Anyone who can help with booting NT 4.0 PPC on QEMU? I still can't get any bios to boot in LE.


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 4:03 pm 
Reply with quote
User avatar
Offline

Joined
Wed Apr 17, 2019 12:44 pm

Posts
133

Location
C:\winnt\system32\ntoskrnl.exe

Favourite OS
All windows versions before 10
ATeamInc wrote:
ItaniumCommando wrote:
I've been trying to run the OG Home Server as a virtual machine under Server 2012 R2 and it's not playing nicely. Under the built-in HyperV it gave me an error stating that "Home Server requires at least 60GB of space" and just refused to install.

I've tried adjusting the virtual hard drive up to 1TB but it still gives me the same message. I've tried dedicating an entire hard drive to the VM and nothing.

Am I missing something here or should I try VMware?

((No wonder I hate Vista..it has the same vibe during setup and it just urked me right then and there :mrgreen:))

Try using a fixed VHD being at least 100-200GB.

ItaniumCommando wrote:
I've been trying to run the OG Home Server as a virtual machine under Server 2012 R2 and it's not playing nicely. Under the built-in HyperV it gave me an error stating that "Home Server requires at least 60GB of space" and just refused to install.

I've tried adjusting the virtual hard drive up to 1TB but it still gives me the same message. I've tried dedicating an entire hard drive to the VM and nothing.

Am I missing something here or should I try VMware?

((No wonder I hate Vista..it has the same vibe during setup and it just urked me right then and there :mrgreen:))

_________________
Image
i am proto
your security is my motto


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 4:08 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Feb 25, 2018 6:49 pm

Posts
233

Location
GMT+2 w/dst

Favourite OS
5xxx series (Vista)
MCpillager12 wrote:
*snip*

Up to means it is not fixed but dynamic... You think I didn't read the post?

_________________
Anyone who can help with booting NT 4.0 PPC on QEMU? I still can't get any bios to boot in LE.


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 5:01 pm 
Reply with quote
Offline

Joined
Sat Feb 03, 2018 8:08 pm

Posts
109
I don’t think it should make a difference, since the vhd might be less than 1tb initially but it will still report it’s size as 1tb to the guest os.
Still, give setting it up as a fixed disk a try if you really want to use hyperv
Edit: actually, it might because home server does a lot of funny storage stuff and it may need access to the whole vhd during setup


Top  Profile
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Tue Jun 11, 2019 7:04 pm 
Reply with quote
User avatar
Offline

Joined
Sun Jul 22, 2018 11:16 pm

Posts
15

Location
Nebraska

Favourite OS
Windows Server 2003 Itanium
I've got a copy of VWmare 14 on hand so I go ahead an try that. It's just really weird that Home Server refuses to install on either the vhd even if I dedicate and entire actual drive to it. Not even og Server 2008 gives me this problem.

Is it just home server being a royal pain behind the scene?

_________________
When in doubt, Windows XP it out!


Top  Profile
 PostPost subject: Windows Home Server VM is a Go!        Posted: Tue Jun 11, 2019 9:06 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Mon Jul 23, 2012 9:40 pm

Posts
1030

Location
MD N10DC

Favourite OS
NT3.X Family
I am going to assume you are installing 2011. 2011 is based on server 2008R2/Win7 ala nt6.1 not NT6.0 (Vista/Server2008R1). As for your question about it being a pain, yes and no. You just need to be a pain back!

Make sure the system is generation 1. Everything else like normal, allot the ram you want.
Except when you get to "Connect Virtual Hard Disk." Create a VHD instead of VHDX. For some reason VHDX doesn't play well with pre nt6.2 os in general under Hyper-V. If it forces you to make vhdx, after you create the vm go to vm hard drive settings and create new vhd (NOT VHDX) of proper size, mine is 200gb. Fixed or not it doesn't matter. Set the vm to use that disk. Also make sure you have it as IDE disk.
Boot it, then you will need to shift-f10 at the welcome screen, and bring up diskpart. Select the disk, likely disk 0, and online the disk
Code:
online disk

and then run
Code:
attribute disk clear readonly

I'd also recommend running
Code:
convert mbr

to initialize the disk.

Then leave diskpart, but leave the command window open. In the command prompt go to the cdrom, then the sources folder and run setup.exe. This lets you run the real server 2008R2 setup and not the nonsense trimmed down halfunattended consumerized setup. If you get to the disk select screen and it goes off about disk not ready because of some bios nonsense, restart the virtual machine. Second time around all you need to do is shift-f10 and run setup from sources on the dvd.

Image

Image

Image

Make sure you have a network switch alloted or oobe will moan and complain about no network and not let you continue. Probably need to install a driver, so if it does moan and complain shift-f10, launch taskmgr and kill "Set Up Windows Home Server 2011" when it complains about no network adapter and prompts to restart. You can then launch explorer and do what you need to do. I didn't have to, setup just let me run through so it's touch and go. Then again I already had a virtual switch allocated so...
Yes I have Server2012R2 Standard, using Hyper-V just like you.

_________________
Quote:
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do it blows your whole leg off"


Top  Profile
 PostPost subject: Re: Windows Home Server VM is a Go!        Posted: Wed Jun 12, 2019 3:39 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Feb 25, 2018 6:49 pm

Posts
233

Location
GMT+2 w/dst

Favourite OS
5xxx series (Vista)
yourepicfailure wrote:
I am going to assume you are installing 2011. 2011 is based on server 2008R2/Win7 ala nt6.1 not NT6.0 (Vista/Server2008R1). As for your question about it being a pain, yes and no. You just need to be a pain back!

He's using the original Home Server based of nt 6.0, which was just called Home Server. (IIRC it was released in 2007).

_________________
Anyone who can help with booting NT 4.0 PPC on QEMU? I still can't get any bios to boot in LE.


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a Go!        Posted: Wed Jun 12, 2019 4:34 am 
Reply with quote
Donator
User avatar
Offline

Joined
Mon Jul 23, 2012 9:40 pm

Posts
1030

Location
MD N10DC

Favourite OS
NT3.X Family
No, the original home server was based on Server 2003R2.

_________________
Quote:
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do it blows your whole leg off"


Top  Profile
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Wed Jun 12, 2019 7:12 am 
Reply with quote
User avatar
Offline

Joined
Sun Jul 22, 2018 11:16 pm

Posts
15

Location
Nebraska

Favourite OS
Windows Server 2003 Itanium
Unfortunately I am using the original Home Server OS from 2007. The one that is 32-bit only? Even though it IS based off Server 2003R2, mine has a more "Windows Vista" like feel to it when installing Or in my case attempting to install.

I PERSONALLY was expecting more of the Server 2003 vibes from the visuals upon setting it up but was just caught off guard. It doesn't have the sleekness to be the newer version. I'll post a screen shot of it if you'd like?

I really do appreciate the advice for the 2011 version though! I have a copy of the new version just have no current interest in using it yet.

_________________
When in doubt, Windows XP it out!


Top  Profile
 PostPost subject: Re: Windows Home Server VM is a Go!        Posted: Wed Jun 12, 2019 12:46 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Feb 25, 2018 6:49 pm

Posts
233

Location
GMT+2 w/dst

Favourite OS
5xxx series (Vista)
yourepicfailure wrote:
No, the original home server was based on Server 2003R2.

Ah yes sorry, my fault.

_________________
Anyone who can help with booting NT 4.0 PPC on QEMU? I still can't get any bios to boot in LE.


Top  Profile  WWW
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Wed Jun 12, 2019 8:32 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Sep 13, 2017 1:26 am

Posts
343

Location
Tlajomulco de Zuñiga, Jalisco, Mexico.

Favourite OS
Windows Longhorn 6.0.4093
ItaniumCommando wrote:
Unfortunately I am using the original Home Server OS from 2007. The one that is 32-bit only? Even though it IS based off Server 2003R2, mine has a more "Windows Vista" like feel to it when installing Or in my case attempting to install.

I know this might sound a bit dumb, but have you set the disk to IDE? Server 2003 can't read SATA without an external driver.

_________________
Image
Registrations are now open. Join us today!


Top  Profile  YIM
 PostPost subject: Re: Windows Home Server VM is a No-Go        Posted: Thu Jun 13, 2019 8:59 am 
Reply with quote
User avatar
Offline

Joined
Sun Jul 22, 2018 11:16 pm

Posts
15

Location
Nebraska

Favourite OS
Windows Server 2003 Itanium
SistemaRayoXP wrote:
ItaniumCommando wrote:
Unfortunately I am using the original Home Server OS from 2007. The one that is 32-bit only? Even though it IS based off Server 2003R2, mine has a more "Windows Vista" like feel to it when installing Or in my case attempting to install.

I know this might sound a bit dumb, but have you set the disk to IDE? Server 2003 can't read SATA without an external driver.


Hm, I'll give that a shot. Windows XP didn't seem affected by the fact I had it set to SATA so I didn't bother on Home Server.

_________________
When in doubt, Windows XP it out!


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 




Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2019

 

Sitemap | XML | RSS


Affiliate