Microsoft KB Archive/93018

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 18:35, 18 July 2020 by 3155ffGd (talk | contribs) (importing KB archive)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Knowledge Base


LMLOGON=1 Is Not Recognized at the Command Line

Article ID: 93018

Article Last Modified on 10/13/2003



APPLIES TO

  • Microsoft Windows for Workgroups 3.1
  • Microsoft Windows for Workgroups Connection 1.0



This article was previously published under Q93018

SYMPTOMS

The Windows for Workgroups network driver does not recognize LMLOGON=1 if you attempt to log on from the command line before starting Windows for Workgroups, or if you attempt to log on from Workgroup Connections. The only entry recognized when starting the network at MS-DOS is LMLOGON=YES.

WORKAROUND

When Control Panel is used to activate LAN Manager validation, it automatically puts an entry of LMLOGON=1 in the [network] section of the SYSTEM.INI file. The only way to log on to a LAN Manager server from the command line is to manually modify this line.

To change this entry:

  1. Using a text editor, open the SYSTEM.INI file.
  2. In the [network] section, change the LMLOGON= entry to:

    LMLOGON=YES

  3. Save the file.
  4. Restart the network services from the MS-DOS command prompt.

The entry LMLOGON=YES is not recognized by the Networks section of Control Panel. Even if the above modification is made, the LAN Manager settings in Control Panel do not display a check in the Logon On To LAN Manager Domain check box.

STATUS

Microsoft has confirmed this to be a problem in Windows for Workgroups version 3.1. This problem does not occur in later versions of the product.


Additional query words: 3.10 Lanman lan man

Keywords: KB93018