Microsoft KB Archive/57779

From BetaArchive Wiki
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.
Knowledge Base


Modifying File and Edit Menus in Compiled QuickBASIC Programs

Article ID: 57779

Article Last Modified on 1/8/2003



APPLIES TO

  • Microsoft QuickBasic Compiler for Macintosh 1.0



This article was previously published under Q57779

SUMMARY

This article describes how to use an updated version of ResEdit to modify the spelling of items in the File and Edit (default) menus (while retaining their functionality) in compiled applications in QuickBASIC. This procedure could be used for changing the menus to a foreign language. However, you cannot change the length of the names with this technique. This applies to the File menu and its Quit command and to the Edit menu and its Undo, Cut, Copy, Paste, and Clear commands.

This information applies to Microsoft QuickBASIC Version 1.00 for the Apple Macintosh.

MORE INFORMATION

The ResEdit program (Version 1.1b3) shipped with QuickBASIC cannot make the modifications shown below. You can use a later version of Apple's ResEdit, Version 1.3d1, which may be obtained from Macintosh user groups or from Apple.

Note that the "MENU" resource in the QuickBASIC editor contains the menus for the editor and doesn't contain the default menus for compiled applications. The default menus (File and Edit) for compiled applications are contained in the "MBRL" resource.

When you compile with the Use Default Menu option (under the Options command on the Run menu) and you don't define your own menus with MENU statements in the program, a compiled program uses the default menus stored in the "MBRL" resource.

You may alter the "MBRL" resource with ResEdit Version 1.3d1. If you compile a program with the Include the Runtime Code option (from the Options command on the Run menu), you can modify the "MBRL" resource in that specific application. An alternative is to modify the "MBRL" resource stored in QuickBASIC (b) or QuickBASIC (d) to force the change on all compiled applications.

To change the default menu in a Macintosh QuickBASIC application, do the following:

  1. Execute ResEdit Version 1.3d1 (newer than the one in QuickBASIC).
  2. Move to the volume and folder containing the application.
  3. Double-click on the application.
  4. Double-click on "MBRL" (Microsoft BASIC Run-Time Library).
  5. Double-click on "MBRL ID = 0".
  6. Choose Find ASCII from the Find menu.
  7. Type Edit and press Find Next.
  8. Modify the desired strings in the rightmost column keeping the length of each string the same (for example, change "Edit" to "Eooo", not to "Eoo" or "Eoooo").
  9. Close three windows.
  10. Answer "Yes" to "Do you want to save <appl>?"
  11. Quit ResEdit (choose Quit from File menu).

The above method can also be used on QuickBASIC (b) or (d) itself. By changing the "MBRL" resource in QuickBASIC, all newly compiled programs will have the altered menu.


Additional query words: MQuickB

Keywords: KB57779