Microsoft KB Archive/51502

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 19:25, 12 August 2020 by X010 (talk | contribs) (X010 moved page Microsoft KB Archive/Q51502 to Microsoft KB Archive/51502 without leaving a redirect: Text replacement - "Microsoft KB Archive/Q" to "Microsoft KB Archive/")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Converting Word for MS-DOS Glossary Contents to WinWord

PSS ID Number: Q51502 Article last modified on 11-02-1994

1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b

WINDOWS

The information in this article applies to:
- Microsoft Word for Windows, versions 1.x, 2.0, 2.0a, 2.0a-CD, and 2.0b - Microsoft Windows operating system versions 3.0 and 3.1

Summary:

Microsoft Word version 4.0, 5.0, or 5.5 for MS-DOS glossary information can be converted to Word version 2.0 for Windows. A macro to perform the conversion is included in one of the three Word for MS-DOS glossary files installed by Setup in your Word for Windows 2.0 program directory. These files include:

40CONVRT.GLY - For converting Word 4.0 for MS-DOS glossaries 50CONVRT.GLY - For converting Word 5.0 for MS-DOS glossaries 55CONVRT.GLY - For converting Word 5.5 for MS-DOS glossaries

In Word for Windows, glossary entries are saved in your global (normal) template, or in a custom template. Word for MS-DOS glossaries are saved in a separate glossary file with a .GLY file extension. For example, the default Word for MS-DOS glossary file is NORMAL.GLY and is located in your Word for MS-DOS program directory.

Note: Word for Windows versions 1.0, 1.1, and 1.1a support conversion of Word 5.0 for MS-DOS glossaries only through use of a macro included in the Word for MS-DOS glossary file CONVERT.GLY installed in the Word for Windows 1.x program directory.

Converting Word for MS-DOS Glossaries to Word for Windows 2.0

Note: Do NOT use your mouse to select options when performing the Word for MS-DOS portion of the glossary conversion process. Doing so may cause an error to occur during conversion.

To convert a Word for MS-DOS glossary for use in Word for Windows 2.0, do the following:

  1. Open a glossary file in Word for MS-DOS.

    In version 5.5, choose Glossary from the Edit menu, and then choose Open Glossary. Select the glossary file 55CONVRT.GLY (located in the Word for Windows directory), and choose the OK button. Choose Close to exit the Glossary dialog.

    In version 5.0, choose Glossary Load from the Transfer menu, select the glossary file 50CONVRT.GLY (located in the Word for Windows directory), and press ENTER.

    In version 4.0, choose Glossary Merge from the Transfer menu, select the glossary file 40CONVRT.GLY (located in the Word for Windows directory), and press ENTER.

  2. In a blank Word for MS-DOS document, type “convert_glossary” (without quotation marks) and press F3.

  3. Word prompts you for a glossary name. Choose the name of the glossary you want to convert. If the glossary you want to convert is not located in the current directory, include the path information to where the glossary file is located. Word converts the glossary, and then stores it in a file in the same location as your original Word for MS-DOS glossary. The file is saved with the same name as your original glossary with the filename extension .CVT.

    For example, if you choose to convert a glossary named MEMO.GLY, Word creates a file with the name MEMO.CVT in the same directory location as MEMO.GLY.

    Note: If you choose to exit Word for MS-DOS after completing these steps, you will be prompted to save changes to the 55CONVRT.GLY, 50CONVRT.GLY, or 40CONVRT.GLY file. Choose No.

  4. Start Word for Windows.

  5. From the File menu, choose New (ALT, F, N).

  6. From the Use Template list, select MSWORD, and choose the OK button.

  7. From the File menu, choose Open (ALT, F, O), and then select the glossary file with the .CVT extension. To list files with a .CVT extension, type *.cvt in the File Name box, and press ENTER.

  8. Word for Windows asks if you want the glossary entries to be available globally to all documents or only to documents based on the template. Select the appropriate option, and choose the OK button.

    If you choose to make the entries available only to a specific template, the macro asks you for a template filename. Type a new name, or type or select an existing template name, and choose the OK button.

Note: Word for Windows templates are limited to a maximum of 150 glossary entries. If you want to convert a Word for MS-DOS glossary with more then 150 entries, you must delete some entries before converting the glossary.

Converting Word for MS-DOS Glossaries to Word for Windows 1.x

To convert a Word for MS-DOS version 5.0 glossary for use in Word for Windows version 1.0, 1.1, or 1.1a, do the following:

  1. Start Word for MS-DOS version 5.0 with a blank document.

  2. Choose Transfer Glossary Load to load CONVERT.GLY (located in the Word for Windows program directory).

  3. In the blank document, type “convert_glossary” (without the quotation marks), and press F3.

    Word prompts you for a glossary name, converts the glossary, and stores it in a file with the same name as your glossary but with the filename extension .CVT. When Word for MS-DOS finishes converting, a message appears to tell you where to find your file.

  4. Start Word for Windows.

  5. From the File menu, choose New, select PCWORD from the Use Template list, and choose the OK button.

  6. From the File menu, choose Open, and select the conversion glossary file with a .CVT filename extension.

  7. Word for Windows asks if you want the glossary entries to belong to the global or template context. Select the desired context, and choose the OK button.

  8. If you choose template, the macro asks you for a template filename. Type a new name, or type or select an existing template name, and choose the OK button.

The macro processes the glossary entries, and automatically saves the template. You can now use the glossary entries in your Word for Windows documents.

Note: Templates in all versions of Word for Windows are limited to a maximum of 150 glossary entries. If you want to convert a Word for MS-DOS glossary with more then 150 entries, you must delete some entries before converting the glossary.

What Is Converted

This conversion process converts all the text and formatting (including date and time formats) with the following exceptions:

  • The gutter margin is changed to 0 (zero).
  • Word for MS-DOS macros are converted to text (they won’t run in Word for Windows).
  • Any limitations imposed by the Word for MS-DOS to Word for Windows converter are adhered to.

Reference(s):

CONVINFO.DOC

KBCategory: kbinterop KBSubCategory: Additional reference words: kbmacro 1.0 1.00 1.1 1.10 1.1a 1.10a 4.0 4.00 5.0 5.00 5.5 5.50 textconv dosword dos ============================================================================= Copyright Microsoft Corporation 1994.