Microsoft KB Archive/255010

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 17:17, 18 July 2020 by 3155ffGd (talk | contribs) (importing KB archive)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Knowledge Base


Visio2000: Internal Error: #2111 or Internal Error: #2522 Error Message

Article ID: 255010

Article Last Modified on 1/27/2007



APPLIES TO

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition



This article was previously published under Q255010

SYMPTOMS

In Visio 2000, when you want to save a drawing as a Visio 5.0 file, you may receive one of the following error messages:

Visio internal error: #2111. Action 1005: Save As. First try closing and reopening the file. Next try restarting Visio.

-or


Visio internal error: #2522. Action 1002: Open.

CAUSE

These errors occur if the drawing contains a custom toolbar that you added by pointing to Toolbars on the View menu, and then clicking Customize. Then in the Customize dialog box, you clicked Attach. They also occur if the drawing contained a custom toolbar that you removed.

RESOLUTION

To work around this behavior, copy the drawing contents to a new drawing, and then save the new drawing as a Visio 5.0 file. To copy the drawing contents to a new drawing:

  1. Open the Visio drawing file that causes the error.
  2. Press CTRL+A to select all the drawing contents, and then press CTRL+C to copy them.
  3. On the File menu, point to New, and then click New Drawing (or select a specific solution type).
  4. In the new drawing file, press CTRL+V to paste the contents that you copied from the other drawing file.
  5. With everything selected, position the shapes.


TIP: To center the shapes on the page, on the Tools menu, click Center Drawing.

  1. Save the drawing as a Visio 5.0 file.


Keywords: kberrmsg kbprb KB255010