Microsoft KB Archive/246814

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 16:13, 18 July 2020 by 3155ffGd (talk | contribs) (importing KB archive)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Article ID: 246814

Article Last Modified on 8/19/2002



APPLIES TO

  • Microsoft Visual SourceSafe 6.0 Standard Edition



This article was previously published under Q246814

SUMMARY

This article describes some of the new and enhanced features of Visual SourceSafe 6.0 and provides links to additional relevant articles in the Microsoft Knowledge Base.

MORE INFORMATION

Installation Procedures

For additional information about installation procedures for Visual SourceSafe 6.0, click the article numbers below to view the articles in the Microsoft Knowledge Base:

246872 INFO: Installation Information for Visual SourceSafe 6.0


238255 HOWTO: Install VSS to a Novell NetWare Server


Fast Get

For additional information about the Fast Get feature, click the article number below to view the article in the Microsoft Knowledge Base:

221576 INFO: How The Fast Get Operation Works in SourceSafe 6.0


Label Promotions

For additional information about label promotions, click the article number below to view the article in the Microsoft Knowledge Base:

246910 INFO: How Do Label Promotions Work in SourceSafe 6.0


OLE Automation

Numerous enhancements are made to OLE Automation in Visual SourceSafe 6.0. Problems in Visual SourceSafe 5.0 are corrected, and additional functionality is added by exposing the SourceSafe Administrative tools to the object model. OLE Automation code that is written for SourceSafe 5.0 should work without problem in SourceSafe 6.0. If any adjustments are needed, they should be minor.

For additional information about OLE Automation in Visual SourceSafe 6.0, visit the following Microsoft Web site:

Archive and Restore

In Visual SourceSafe 6.0, you can access the Archive and Restore functions from within the SourceSafe Administrative menus. These commands were previously accessible only from the command prompt.

For additional information about the Ssarc.eve and the Ssrestor.exe utilities, click the article number below to view the article in the Microsoft Knowledge Base:

176875 INFO: The Primary Functions of Ssarc.exe and Ssrestor.exe


Project Level Differences

In Visual SourceSafe 5.0, the Project Difference option compares your current project against the version of the project that is stored in the user working directory. In Visual SourceSafe 6.0, the Project Difference option also allows you to compare the contents of projects with other Windows folders or other projects in your database. Specifically, it allows you to compare:

  • VSS project to VSS project
  • VSS project to local folder
  • Local folder to local folder

The addition of Browse buttons lets you specify how to perform the Project Difference operation. To change the default behavior of this command, just choose between Browse buttons.

Deploy Files from the Graphical User Interface (GUI)

Once a project has been designated as a Web project in the Visual SourceSafe administrator, the Deploy option becomes available within the Visual SourceSafe explorer. Visual SourceSafe 5.0 allows you to deploy only entire projects from the GUI. Visual SourceSafe 6.0 lets you deploy individual files as well as entire projects.

Move Command Moves Files and Projects

In Visual SourceSafe 5.0, the Move Project command, which is located on the File menu, lets you move projects. In Visual SourceSafe 6.0, this command has been improved and renamed the Move command. If you select a project and click Move from the File menu, the command works exactly as the Move Project command does in Visual SourceSafe 5.0.

Visual SourceSafe 6.0 gives you the added ability to move individual files between projects. To move a file from one project to another, select the file you want to move. From the File menu, click Move, and then choose the destination project from the Move command window.

When you move a file in Visual SourceSafe 6.0, the file is copied to the destination project and is given the shared file glyph. The original is deleted but is not purged from its starting location. In other words, the Move operation shares the file to the new project, and then deletes (but does not purge) the file from its original project.

Create Database

In Visual SourceSafe 6.0, the administrator of a database can create a new database from within the Administrative utility (Ssadmin.exe). To do this, from the Tools menu, click Create Database.

For additional information about the Create Database command, click the article numbers below to view the articles in the Microsoft Knowledge Base:

216115 HOWTO: Set Up Multiple Databases in Visual SourceSafe 6.0


238155 HOWTO: Create a New Database in Visual SourceSafe


Clean Up Temp Directory

Visual SourceSafe creates temporary files that are usually destroyed during a normal session. Sometimes, due to unusual circumstances, these temporary files remain in the Temp folder and take up disk space.

In Visual SourceSafe 5.0 and earlier, the administrator must explicitly open the Temp folder and delete the files. In Visual SourceSafe 6.0, the administrator can automatically delete temporary files by using the Clean up Temp Directory command. To do so, perform the following steps:

  1. Open the Visual SourceSafe Admin program.
  2. Open the Visual SourceSafe database that contains the Temp folder that you want to clean up.
  3. On the Tools menu, click Clean up Temp Directory.

It is strongly recommended that all users log out of Visual SourceSafe before using the Clean up Temp Directory command; otherwise, data may be lost. However, if Visual SourceSafe finds a file in the Temp folder that is in use (that is, a user is viewing the file), it does not delete the file.

Create Shortcut

The Create Shortcut feature provides an easy way to access a SourceSafe project. Once a shortcut has been created, you can double-click the shortcut icon to open the SourceSafe explorer to the designated project.

To create a shortcut, perform the following steps:

  1. Open the Visual SourceSafe explorer.
  2. Select the project.
  3. On the File menu, click Create Shortcut.

Note that the shortcut for the project should be placed on your desktop.

For additional information about how to use this feature, click the article numbers below to view the articles in the Microsoft Knowledge Base:

167134 HOWTO: Open Visual SourceSafe to a Specific Project


176350 HOWTO: Open Visual SourceSafe to a Specific Database


REFERENCES

For additional information, visit the following Microsoft Web site:

Keywords: kbinfo kbssexplorer kbsetup kbautomation kbcommandline KB246814