Microsoft KB Archive/175120

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 15:38, 18 July 2020 by 3155ffGd (talk | contribs) (importing KB archive)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Knowledge Base


PRB: Error '80004005' Performing Insert or Update on Database

Article ID: 175120

Article Last Modified on 9/30/2003



APPLIES TO

  • Microsoft Commerce Server 2.0



This article was previously published under Q175120

SYMPTOMS

When you perform inserts or updates on the database, you receive the following error message:

Commerce.Datasource.1 error '80004005'
At least one parameter contained a type that is not supported.

CAUSE

This problem occurs because a newer version of Msdadc.dll is installed on the system by Microsoft Internet Explorer version 4.0 beta release.

WORKAROUND

To work around the problem, use either of the following methods:

  • Install the release version of Internet Explorer 4.0.


-or-

  • Replace the newer version of Msdadc.dll with the older one. This DLL file is in the C:\Program Files\Common Files\System\Ole Db folder. Locate the newer version of the file and rename it. Copy the older version of the Msdadc.dll file to the same location. All the Commerce stores should now work correctly. Note that there might be other scripting errors when you run the Store Builder Wizard to create a new store. Hence, it is a good idea to install the release version of Microsoft Internet Explorer version 4.0.


Note that the older version of the Msdadc.dll file is available on the OLEDB Software Development Kit (SDK 1.0) or from a computer that does not have Internet Explorer 4.0 beta installed.



Additional query words: IE

Keywords: kberrmsg kbprb KB175120