Microsoft KB Archive/172380

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 10:06, 21 July 2020 by X010 (talk | contribs) (Text replacement - """ to """)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

WD95: Macros in CONVERT7, LAYOUT7, TABLES7, and MACROS7 Template

Q172380



The information in this article applies to:


  • Microsoft Word for Windows 95, versions 7.0, 7.0a





SUMMARY

After running a Complete installation of Microsoft Word for Windows 95, the following macro templates are copied to the MACROS subdirectory in the Word 7.x program directory (for example, C:\Microsoft Office\Winword\Macros).

CONVERT7.DOT

MACROS7.DOT
TABLES7.DOT

LAYOUT7.DOT

This article contains a list of the macros in each of these templates, including notes about their limitations or any problems.

NOTE: The Typical Setup option does not install these templates to the MACROS subdirectory.

The CONVERT7.DOT template contains the following useful macros to simplify converting and changing conversion options.

   Macro                       Explanation and Notes
   -------------------------------------------------------------------
   BatchConverter              Runs a wizard that helps you select and
                               convert multiple files from another
                               format to Word or vise versa.

   EditConversionOptions       Opens a dialog box that allows you to
                               customize file conversion settings. The
                               macro changes the conversion options by
                               changing the settings in the MSTXTCNV.INI
                               file. 

The MACROS7.DOT template contains the following useful macros you can use in your general work with Word for Windows:

   Macro                       Explanation and Notes
   ----------------------------------------------------------------------

   AutoNew                     When you open a new document based on this
                               template, this macro will run and will
                               display a new toolbar called Run Sample
                               Macros. The macros listed in this
                               template are designed to be run by this
                               toolbar. When you click the toolbar, a Run
                               Sample Macro dialog box appears, listing
                               the following macros:

                                   DisableAutoBackup
                                   EnableAutoBackup
                                   ExitAll
                                   FindSymbol
                                   FontSampleGenerator
                                   InsertFootnote
                                   MindBender
                                   NormalViewHeaderFooter
                                   OrganizationalChartMaker
                                   RegOptions
                                   RunSampleMacros
                                   SaveSelectionToTextFile
                                   SetPrintFlags
                                   SuperDocStatistics
                                   WordPuzzler

   AutoOpen                    When you open this template, this macro
                               will run and will display a new toolbar
                               as described in the AutoNew explanation and
                               notes.

   DisableAutoBackup           Disables the Enable/Disable Auto Backup
                               command on the File menu (added by the
                               EnableAutoBackup macro) and removes the
                               FileSave and FileSaveAs macros.

   EnableAutoBackup            Adds the Enable/Disable Auto Backup command
                               to the File menu. It also creates FileSave
                               and FileSaveAs macros that create backups
                               when you save files. The macro prompts you
                               for a location to save the backups to.

   ExitAll                     Closes all open document, template, and
                               macro-editing windows. A dialog box lists
                               all open documents and prompts you to save
                               them.

   FindSymbol                  Finds and replaces symbols inserted with
                               the Symbol command (Insert menu). In the
                               Find And Replace Symbols dialog box, choose
                               the Find What button to select the symbol to
                               search for; choose the Replace With button
                               to select the symbol to replace it with.

   FontSampleGenerator         Generates a sample document that you can
                               print out to show all printable fonts on
                               your system in the point size you specify.

   InsertFootnote              A wizard that helps you create footnotes
                               according to the "Chicago Manual of Style"
                               or "The Modern Language Association" (MLA).

   MindBender                  Demonstrates, through a sample game, several
                               methods for using dynamic dialog boxes.

   NormalViewHeaderFooter      Edit header and footers Word for Windows 2.0
                               style, using header and footer panes in
                               Normal view.

   OrganizationalChartMaker    Builds an organizational chart using the
                               drawing tools in Word. Set up the hierarchy
                               using built-in heading styles (do not
                               include any tab characters), and run the
                               macro.

   RegOptions                  View and change Word 7.x options in the
                               Windows registry files.

   RunSampleMacros             Displays a dialog box that allows you to
                               easily run any of the sample macros included
                               in Macros7.dot. Used in the Word 7.x Sample
                               Macros toolbar.

   SaveSelectionToTextFile     Saves selected Word text to disk as a
                               standard unformatted text file in one
                               operation. Supports both ANSI and ASCII
                               character sets.

   SetPrintFlags               A Product Support Services support macro.
                               Modifies advanced printing behavior. Use
                               with caution.

   SuperDocStatistics          Displays a dialog box with a comprehensive
                               list of the open document's statistics. For
                               example, all fonts used in the document are
                               listed.

   WordPuzzler                 A popular puzzle implemented in a WordBasic
                               macro. 

The TABLES7.DOT template contains the following useful macros you can use when working with tables:

   Macro                       Explanation and Notes
   -------------------------------------------------------------------
   AccessExporter              Converts a selected Word table into a
                               Microsoft Access table.

   TableMath                   Helps you insert formula fields into a
                               table by selecting cell references and
                               calculation types such as sum, average,
                               and count. Position the insertion point
                               in the table, and run the macro.

                               For more information about the TableMath
                               macro, see the following article in
                               the Microsoft Knowledge Base: 

Q110165 TableMath Macro: Purpose, Usage, and Issues

   TableNumber                 Adds numbering to rows or columns. If
                               necessary, a row or column is added to
                               contain the numbering. Position the
                               insertion point in the table, start the
                               macro, and select the numbering option
                               you want from the dialog box. 

The LAYOUT7.DOT template contains the following useful macros you can use to manipulate text and page layouts.

   Macro                       Explanation and Notes
   -------------------------------------------------------------------
   ArrangeWindows              Displays a dialog box where you can choose
                               to arrange all open windows tiled,
                               horizontally, vertically, or cascaded.

   Cascade                     Rearranges all open windows so they overlap
                               in a cascade.

   DecreaseLeftAndRightIndent  Decreases the indent for the selected
                               paragraphs an equal amount towards the left
                               and right margins using the default tab
                               settings.

   IncreaseLeftAndRightIndent  Indents selected paragraphs an equal amount
                               from the left and right margins using the
                               default tab settings.

   Overscore                   Adds an overscore to selected text by
                               replacing the text with an EQ (Equation)
                               field.

                               Limitations:

                                - "Selection is invalid" error
                                  when text includes a paragraph mark or
                                  when text wraps to a second line.


                                - After running Overscore macro, Undo
                                  is unavailable. To undo, copy text
                                  from EQ field.

   PrintableCharacters         Creates a document containing all printable
                               characters for a font. When you run the
                               macro, a custom font dialog box is
                               displayed so you can choose the font.

   SectionManager              Displays all section-level formatting in
                               one dialog box. You can also modify section
                               formatting using the Page Setup, Page
                               Numbers, and Columns buttons.

   TileHorizontally            Tiles all open documents horizontally.

   TileVertically              Tiles all open documents vertically. 

Additional query words: 7.0 word7 word95

Keywords : kbtemplate kbofficeprog
Issue type : kbinfo
Technology :


Last Reviewed: March 28, 2000
© 2001 Microsoft Corporation. All rights reserved. Terms of Use.