Microsoft KB Archive/163103

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 11:01, 21 July 2020 by X010 (talk | contribs) (Text replacement - """ to """)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Article ID: 163103

Article Last Modified on 11/23/2006



APPLIES TO

  • Microsoft Excel 97 Standard Edition



This article was previously published under Q163103


SUMMARY

To programmatically create a graphics file from a Microsoft Excel chart, use the Export method. This article contains a sample Microsoft Visual Basic for Applications macro that creates a .gif file from a chart in a Microsoft Excel workbook.

NOTE: If you click Save As HTML on the File menu and use the Internet Assistant Wizard to create an .htm document, it creates a .gif file for each of the charts in the workbook. No other graphic objects can be saved as .gif files from Microsoft Excel.

MORE INFORMATION

Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability and/or fitness for a particular purpose. This article assumes that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific needs. If you have limited programming experience, you may want to contact a Microsoft Certified Partner or the Microsoft fee-based consulting line at (800) 936-5200. For more information about Microsoft Certified Partners, please visit the following Microsoft Web site:

For more information about the support options that are available and about how to contact Microsoft, visit the following Microsoft Web site:

The following sections explain how to create an embedded chart and the macro code that generates a .gif file from the chart.

Creating the Chart

  1. Save and close any open workbooks, and then create a new workbook.
  2. Type the following data in Sheet1:

    A1: a B1: 5
    A2: b B2: 10
    A3: c B3: 7
  3. Select the range A1:B3 and click Chart on the Insert menu.
  4. In the "Chart Wizard - Step 1 of 4 - Chart Type" dialog box, click Finish.

    This creates an embedded chart in Sheet1.

Sample Macro for Creating a .gif File

  1. Start the Visual Basic Editor (press ALT+F11).
  2. On the Insert menu, click Module.
  3. Type the following code in the Visual Basic module:

          Sub Create_GIF()
             Dim mychart As Chart
             Set mychart = ActiveSheet.ChartObjects(1).Chart
             mychart.Export FileName:="c:\Mychart.gif", FilterName:="GIF"
          End Sub
                            
  4. Press ALT+F11 to switch to Microsoft Excel.
  5. On the Tools menu, point to Macro, and then click Macros.
  6. Click the Create_GIF macro, and then click Run.

    The file Mychart.gif is created in the root directory of drive C.


REFERENCES

For more information about the Export method, click the Office Assistant in the Visual Basic Editor, type export, click Search, and then click "Export Method."

NOTE: If the Assistant is hidden, click the Office Assistant button on the Standard toolbar. If the Assistant is not able to answer your query, please see the following article in the Microsoft Knowledge Base:

176476 OFF: Office Assistant Not Answering Visual Basic Questions



Additional query words: 97 XL97

Keywords: kbcode kbhowto kbprogramming kbualink97 KB163103