Microsoft KB Archive/101377

From BetaArchive Wiki
< Microsoft KB Archive
Revision as of 18:13, 12 August 2020 by X010 (talk | contribs) (X010 moved page Microsoft KB Archive/Q101377 to Microsoft KB Archive/101377 without leaving a redirect: Text replacement - "Microsoft KB Archive/Q" to "Microsoft KB Archive/")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

INF: Supported Versions of Windows Sockets PSS ID Number: Q101377 Article last modified on 04-28-1994

3.10

WINDOWS NT

The information in this article applies to:
- Microsoft Win32 Software Development Kit (SDK) for Windows NT, version 3.1 - Microsoft Win32s versions 1.0 and 1.1

When using the WSAStartup() Windows Sockets application programming interface (API)

int PASCAL WSAStartup ( WORD wVersionRequired, LPWSADATA lpWSAData );

the first parameter specifies the version of Windows Sockets the application requires.

The 16-bit Windows Sockets dynamic-link library (DLL) for Windows NT (WINSOCK.DLL) supports versions 1.0 and 1.1.

The 32-bit Windows Sockets DLL for Windows NT (WSOCK32.DLL) supports only version 1.1. Specifying version 1.0 in the call to WSAStartup() results in a return of WSAVERNOTSUPPORTED.

The Win32s WSOCK32.DLL thunks down to the 16-bit WINSOCK.DLL, if it is installed. Win32s 1.1 also requires Windows Sockets 1.1 to provide the thunks.

Additional reference words: 1.00 1.10 3.10 KBCategory: Prg KBSubcategory: NtwkWinsock

=================================================================

Copyright Microsoft Corporation 1994.