Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/925316

From BetaArchive Wiki
Knowledge Base


Error message when you install an .msu update package on a computer that is running Windows Vista: "The Windows Modules Installer must be updated before you can install this package"

Article ID: 925316

Article Last Modified on 10/31/2007



APPLIES TO

  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition



SYMPTOMS

When you install an .msu update package on a computer that is running Windows Vista, you may receive the following error message:

The Windows Modules Installer must be updated before you can install this package. Please update the Windows Modules Installer on the computer, then retry Setup.

When you use a script to install the .msu update package, the installation fails. When this problem occurs, the Wusa.exe process returns error code 0x800f0823.

CAUSE

This problem occurs because the installation requires a new version of the Windows Modules Installer.

RESOLUTION

To resolve this problem, use Windows Update to update the Windows Modules Installer.

MORE INFORMATION

When you use Windows Update, the Windows Modules Installer update is required. However, when you install an .msu update package, the Setup program does not connect to Windows Update to update the Windows Modules Installer.

Keywords: kbtshoot kbprb kbexpertisebeginner KB925316