Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/92459

From BetaArchive Wiki
Knowledge Base


PSS ID Number: 92459

Article Last Modified on 1/8/2003



The information in this article applies to:

  • Microsoft Visual Basic for MS-DOS 1.0



This article was previously published under Q92459

SYMPTOMS

Starting VBDOS.EXE and making some changes to the default code window and then canceling the saving of any changes before shelling out to the Forms Designer (FD.EXE), can cause the Forms Designer to incorrectly load an existing project makefile and function incorrectly.

STATUS

Microsoft has confirmed this to be a bug in the Standard and Professional Editions of Microsoft Visual Basic for MS-DOS, version 1.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The following steps will duplicate this problem:

  1. Create a Project (Project1.mak) that contains two forms. For example: Form1.frm and Form2.frm.
  2. Exit VBDOS.EXE and Restart it.
  3. Add some code to the default code window (Untitled). For example:

            PRINT "hello"
  4. From the File menu select New Form.
  5. The Dialog box appears, select OK to Form1.frm.
  6. The Dialog box appears, select OK to Project.mak. This sets an internal flag. VBDOS.EXE now recognizes the current project to be Project.mak.
  7. The Dialog box appears, select OK to "File exists overwrite".
  8. The Dialog box appears, select CANCEL on Save as untitled.bas. This cancels the whole operation and nothing is saved out to disk, but the internal setting of the project as Project.mak is still set.
  9. From the File menu select Remove File.
  10. The Dialog box appears, select OK to remove untitled.
  11. The Dialog box appears, select NO to "File has been modified...". By selecting no you prevent the project file Project.mak from being updated on disk.
  12. The Dialog box appears, select OK to "untitled as new startup". The old untitled message has been removed and now all is back to as it was when you started VBDOS.EXE except that the project internally is still flagged as Project.mak.
  13. From the File menu select New Form.
  14. The Dialog box appears, select OK to Form1.frm.
  15. The Forms Designer (FD.EXE) is now loaded. However, when VBDOS.EXE shells out to the Forms Designer, the current project information is set to Project.mak and this information is then passed to the Forms Designer, which causes the Forms Designer to load in the existing project on disk, which is not the one you were working on.
  16. The Forms Designer starts up with Project.mak. Two forms are loaded (Form1 and Form2), and the current form to be edited is now Form3, not Form1 as you specified back in VBDOS.EXE.
  17. From the View menu select Forms... to view all forms in the project. Form1 and Form2 are there but Form3, the current form is not listed.



Additional query words: VBmsdos buglist1.00 1.00

Keywords: KB92459
Technology: kbAudDeveloper kbVB100DOS kbVBSearch kbZNotKeyword3