Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/923915

From BetaArchive Wiki

Article ID: 923915

Article Last Modified on 10/15/2007



APPLIES TO

  • Microsoft Office Visio Professional 2007



SYMPTOMS

You import data from a Microsoft Excel workbook by using a Open Database Connectivity (ODBC) data source name (DSN) data source connection to link to shapes in a Microsoft Office Visio 2007 drawing. When you do this, one of the following symptoms may occur:

  • A named range is not listed in the Select Database and Table pane of the Data Connection wizard.
  • If you click to clear the Connect to a specific table check box in the Select Database and Table pane, and then finish the Data Connection wizard, you receive the following error message:

    The data source contains no visible tables.


CAUSE

This issue may occur when the Excel worksheet contains a named range that includes either 65,535 rows or 255 columns, or both.

WORKAROUND

To work around this issue, use one of the following methods.

Method 1: Import data from an Excel workbook without using a ODBC DSN data source connection

To do this, follow these steps:

  1. On the Data menu, click Link Data to Shapes.
  2. Click Microsoft Office Excel workbook, and then click Next.
  3. Click Browse, select the Excel workbook that contains the data, and then click Open.
  4. Click Next.
  5. Complete the Data Selector wizard as you typically do.

For more information about how to connect to an Excel workbook, click Microsoft Office Visio Help on the Help menu, type data selector wizard excel in the Type words to search for box, and then click Search to view the topic.

Method 2: Use an Excel worksheet that does not contain a named range

To work around this issue, use an Excel worksheet that does not contain a named range. Then, select the range that you want to use in the Excel worksheet in the Data Selector wizard.

To do this, follow these steps.

Note Excel must be installed on the computer to complete these steps.

  1. On the Data menu, click Link Data to Shapes.
  2. Click Microsoft Office Excel workbook, and then click Next.
  3. Click Browse, select the Excel workbook that contains the data that you want to use, and then click Open.
  4. Click Next.
  5. If the workbook contains several worksheets that contain data, select the appropriate worksheet in the What worksheet or range do you want to use box, and then click Select Custom Range.
  6. Excel starts automatically. In the Excel worksheet, select the range of your data. The range of the data that you select is automatically filled in in the Select Range box of the Import to Visio dialog box.
  7. Click OK to close the Import to Visio dialog box. Excel closes, and the range that you selected is appended to the worksheet name in the What worksheet or range do you want to use box of the Data Selector wizard.
  8. Complete the Data Selector wizard as you typically do.



Additional query words: visio2007 visio2k7 visio12 vso2007 vso2k7 vso12 linkdatatoshapes dataselector data selector

Keywords: kberrmsg kbtshoot kbimport kbprb kbexpertisebeginner kbdataaccess KB923915