Microsoft KB Archive/50280

From BetaArchive Wiki

Works: Importing and Exporting MORE II Documents

PSS ID Number: Q50280 Article last modified on 06-10-1996

2.00

MACINTOSH

The information in this article applies to:
- Microsoft Works for the Macintosh, version 2.0

SUMMARY

In Microsoft Works, you can import MORE II text files only. That is, MORE II graphic elements must be copied and pasted. This article covers transferring outlines only.

MORE INFORMATION

To import text files from MORE II to the Works Word Processor, do the following:

  1. Make sure that the MacWrite filter, which comes with MORE II, is located in the System Folder.
  2. From the File menu, choose Save As (to export the entire file) or Send To (to export the current selection).
  3. Select the MacWrite filter and save the document.

This file can then be opened in Works. Any formatting that MacWrite supports is retained. For example, font information is retained but color is not.

Anomalies

  1. If the outline has labels attached to the subheadings (controlled with the Labels command on the Format menu), the MacWrite document indents each subheading slightly, allowing room for these labels. This problem occurs regardless of whether the No Labels option is selected in the Save As dialog box in MORE II (this option allows the labels to be suppressed during the transfer).

    To avoid this slight indentation, select No Labels under Labels on the Format menu.

  2. MacWrite does not support manual page breaks. If the MORE outline has any page breaks, MORE tries to leave a gap in the document sufficient to force an automatic page break. This gap most likely is too large for Works; therefore, some space must be deleted so that the following page text is snug against the top of the page.

  3. Works interprets 1.5-spaced text as single-spaced, and double-spaced text as 1.5-spaced.

To import text files from MORE II to the Works Database or Spreadsheet, do the following:

  1. Make sure that the Plain Text filter, which comes with MORE II, is located in the System Folder.
  2. From the File menu, choose Save As (to export entire file) or Send To (to export the current selection).
  3. Select the Plain Text filter and save the document. The document is converted to a tab-delimited text file, with each sublevel represented by one tab.
  4. This file can then be opened in the Database or Spreadsheet.

Anomalies

  1. The MORE document exports to a format that makes no sense in the Spreadsheet or the Database. The first record/row contains the first subheading, the second record/row contains the second subheading (which is tabbed over to the second field/column), and so on.

  2. When labels are exported with the outline, Works reads an extra tab in front of document text. (This is simply a special type of subheading in MORE to deal with long text. It is the equivalent of document text in a Microsoft Word outline.) With labels, all document text is imported as tabbed over in the same column as the next level of subheadings. Without labels, the document text is imported in the same column as the subheading it follows.

    Note that this behavior local to a given subheading; that is, the subheadings with labels export the extra tab in front of their respective document text, and the opposite is true for any subheadings that do not have labels.

To export Works documents to MORE II, use the appropriate method below:

Exporting from the Word Processor

  1. Save the Word Processor document as text only (select Export from the Save As dialog box).

  2. Open MORE II.

  3. Make sure that the Plain Text filter, which comes with MORE II, is located in the System Folder.

  4. From the File menu, choose Open (to create a new untitled document) or Receive From (to import into the current document).

    Note that individual selections can be copied and pasted into MORE’s bullet charts (either text or graphics) and tree charts (as text only).

Exporting from the Database or Spreadsheet

  1. Save the Spreadsheet or Database document as text only.

  2. Open MORE II.

  3. Verify that the Plain Text filter, which comes with MORE II, is located in the System Folder.

  4. From the File menu, choose Open (to create a new untitled document) or Receive From (to import into the current document).

    Note that individual selections can be copied and pasted into MORE’s bullet charts (either text or graphics) and tree charts (as text only).

Anomalies

  1. Each entire row from Works is treated as a subheading. These subheadings contain each column element separated by a tab. Therefore, the resulting file has as many headings as the number of rows that were exported from Works.
  2. MORE cannot distinguish levels in text files. This means that the first row is at a given level (Level One if Open was used, or the level of the current selection if Receive From was used), and the following rows are one indentation (or one subheading) lower than the first record.
  3. Text files can be imported only into MORE’s Outline format (and not as bullet or tree charts).

KBCategory: kb3rdparty kbother KBSubcategory: macworkskb

Additional reference words: 2.00 moveart

Copyright Microsoft Corporation 1996.