Microsoft KB Archive/37415

From BetaArchive Wiki
Knowledge Base


QuickBasic 4.50 and Earlier May Not Work with MS-DOS 4.00

Article ID: 37415

Article Last Modified on 11/21/2006

This article was previously published under Q37415

SUMMARY

QuickBasic Version 4.50 and earlier releases have not been tested with MS-DOS Version 4.00. Microsoft does not claim that QuickBasic Version 4.50 (and earlier versions) will work with MS-DOS Version 4.00. QuickBasic Versions 4.00, 4.00b, and 4.50 require a DOS version between Versions 2.10 and 3.x.

QuickBasic may not work correctly with MS-DOS Version 4.00 because of memory-management issues. In particular, the SHELL feature fails, both from Shell in the File menu in the QB.EXE editing environment and from the SHELL statement in a compile program.

The "Make .EXE" function of QuickBasic will also not work properly in MS-DOS Version 4.00, because it requires a SHELL to BC.EXE and LINK.EXE. BC.EXE will work from the MS-DOS command line.

CHAIN statement failures have also been reported with QuickBasic operating under MS-DOS Version 4.00.


Additional query words: QuickBas

Keywords: KB37415