Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/254912

From BetaArchive Wiki

PSS ID Number: 254912

Article Last Modified on 6/4/2003



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition
  • Microsoft Visio Standard 5.0x
  • Microsoft Visio Professional 5.0x
  • Microsoft Visio Technical 5.0x
  • Microsoft Visio Enterprise 5.0x



This article was previously published under Q254912

SUMMARY

This article shows you how to change the default text for a master shape or for the text tool. This article assumes that you know how to change the default text and that you understand styles and how they relate to the text. To learn more about how Visio uses styles, you may want to read the sections pertaining to styles in Visio Help. After you know how to use styles, the contents of this article, which outlines the steps required for changing the default text, may be easier to follow.

This article contains the following sections:

  • Changing the Default Text Style for Master Shapes
  • Changing the Text Style for Existing Shapes on a Drawing Page
  • Changing the Default Text for the Text Tool


MORE INFORMATION

Changing the Default Text Style for Master Shapes

Changing the default text style for shapes involves three sets of steps. The first set explains how to determine what style is assigned to the text of each shape. The second set explains how to change the attributes of the assigned style. A third set explains how to make the changes to your template permanent.

To begin, start your edition of Visio and open the Flowchart template. The following exercise steps you through changing the default text for shapes associated with this template. You can use these same steps for any template. Keep in mind that all shapes in a template may not all have the same text style; therefore, so you may need to modify more than one style to affect all shapes.

To determine the text style of each shape:

  1. Drag the Process, Data, and Decision shapes to your drawing page.


[GRAPHIC: Image of Process, Data, and Decision shapes ]

  1. Select the Process shape, and then click Styles on the Format menu.


Note that there are three style settings in the Styles dialog box: Text, Line, and Fill. Each of these settings represents a formatting element for the shape. The name next to each setting is the name of the style assigned to that element.

  1. Note the name of the style assigned to the text. The Process shape's text style is called "Flow Normal."


[GRAPHIC: Image that shows "Flow Normal" as the style assigned to the text.]

  1. Click OK to close the Styles dialog box.

To change the attributes of the assigned text style:

  1. On the Format menu, click Define Styles.
  2. In the Style box of the Define Styles dialog box, select Flow Normal.
  3. Under Change, click Text to edit the attributes of this style's text.


[GRAPHIC: Image of the Define Styles and Font Boxes in which you can edit the attributes of the style's text. ]

  1. In the Text dialog box, change the font, point size, and any other text-related settings that you want to use as defaults.
  2. Click OK to return to the Define Styles dialog box.
  3. Click Change to save the new text settings.
  4. Click OK or Apply. (Only one of these options is available, depending on whether or not a shape is selected.)

Note that the three shapes that you dragged to the drawing page now all display the changes that you just made to the text style. Any shape that has the "Flow Normal" style assigned to its text will also show these changes, whether "Flow Normal" is assigned as a default to a shape in the stencil, or you assign it manually. So, for example, because the Internal Storage and Document shapes also include the "Flow Normal" text style, the new settings apply to these shapes when you drag them to the drawing page.

NOTE: Following steps 1 through 7 to change the default text will affect your current drawing only.

To make the changes to the template permanent:

  1. Save the drawing as a template.
  2. Use the new template each time that you create a new drawing for which you would like to use the new settings. (See Visio Help for information on saving templates.)

Changing the Text Style for Existing Shapes on a Drawing Page

You can change the text style for multiple shapes on a drawing page without modifying styles.

Keep in mind that this only affects shapes that are already on the drawing page. In this example, there is no way to save the text modifications for future drawings. To change the text for multiple shapes:

  1. Select all the shapes with the pointer tool (or click Select All on the Edit menu).
  2. On the Format menu, click Text, and then modify the font, point size, and any other text settings.
  3. When you have completed the changes, click OK. The new text settings will be applied to the selected shapes.

Changing the Default Text for the Text Tool

You use the text tool to create independent text blocks (text that isn't associated with a shape). The text blocks you create take on the style assigned to the text tool. Styles assigned to the text tool work a little differently than styles assigned to master shapes in that you can actually assign a default style to the text tool before you use it.

If you use the text tool and let Visio choose the text style, Visio will pick "Normal." To get the characteristics that you want, you can edit the style called "Normal" as described in steps 1 through 7 of the "To change the attributes of the assigned text style" section earlier in this article. Alternatively, you can assign a default style that applies to all text blocks that you create after assigning the style.

To assign a text style to the text tool:

  1. Make sure nothing on your page is selected, and then click Style on the Format menu.
  2. In the Text Style box of the Style dialog box, select the style that you want to assign to the text tool.


NOTE: If none of the styles match the characteristics you are looking for, you can define a new text style by using the Define Styles dialog box, and then assign the new style in the Style dialog box.

  1. Click OK.

When you create an independent text block with the text tool, Visio applies the style that you assigned to the text. If you decide to assign a different style later, the new settings will apply only to text that you add after making the changes.

Keywords: kbGraphxLink kbgraphxlinkcritical KB254912
Technology: kbVisio2000Search kbVisio500xSearch kbVisioSearch kbZNotKeyword3