Microsoft KB Archive/248956

From BetaArchive Wiki
Knowledge Base


ACC2000: Compilation Errors and Extended Characters in Module after Converting to Access 2000

Article ID: 248956

Article Last Modified on 11/25/2002



APPLIES TO

  • Microsoft Access 2000 Standard Edition



This article was previously published under Q248956

Novice: Requires knowledge of the user interface on single-user computers.

This article applies only to a Microsoft Access database (.mdb).


SYMPTOMS

When you convert a database to Access 2000, you may receive the following error message:

There were compilation errors during the conversion or enabling of this database.

The database has not been saved in a compiled state. The performance of this database will be impaired because Microsoft Access will need to recompile the database for each session.

For information on improving performance, click Help.

When you click OK, the conversion is completed. Then you notice that extended characters appear in red in one or more of your Visual Basic for Applications modules.

RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:

245025 OFF2000: How to Obtain and Install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)


You may be able to temporarily work around this problem by compiling and compacting the database in Access 97.

If that does not work, try the following steps:

  1. Reopen the original database in Access 97.
  2. Open the module in which you saw the extended characters in Access 2000.
  3. On the Edit menu, click Select All, and then on the Edit menu, click Copy.
  4. Close the module.
  5. Click New to create a new module.
  6. If they are present, delete the Option Compare Database and Option Explicit statements, so that the entire module is blank.
  7. On the Edit menu, click Paste. You see all the code appear from the old module.
  8. On the File menu, click Save. You can leave the module name in the Save As dialog box unchanged. Click OK.
  9. Select the old module and on the Edit menu, click Delete. A dialog box prompts you if you are sure. Click Yes.
  10. Select the new module, and then on the Edit menu, click Rename.
  11. Give the new module the name of your old module.
  12. Close the database and try converting it again in Access 2000.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.


Additional query words: pra weird strange unusually unwanted

Keywords: kberrmsg kbbug kbfix KB248956