Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/173504

From BetaArchive Wiki

Article ID: 173504

Article Last Modified on 1/20/2007



APPLIES TO

  • Microsoft Word 97 Standard Edition
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c



This article was previously published under Q173504

SUMMARY

Some Microsoft Word macro viruses remove the Macro or Customize commands on the Tools menu, or make these commands unavailable. This article describes several ways to restore these menu items after you have used third party anti-virus software to remove the macro virus from your system.

MORE INFORMATION

Use either of the following methods to restore the missing menu items.

Method 1: Use Customize for Menus

Use the appropriate method for your version of Word.

Microsoft Word 97:

  1. On the View menu, point to Toolbars, and then click Customize.
  2. On the Toolbars tab, click to select Menu Bar.
  3. Click Reset, and then click Close.

NOTE: If this method does not restore Macro and Customize to the Tools menu, close and restart Word. If the Macro and Customize commands are still missing from the Tools menu, follow the steps under method 2 to rename the Normal template.

Microsoft Word 6.x and 7.x:

  1. On the View menu, click Toolbars, and then click Customize.
  2. Click the Menus tab.
  3. Under Categories choose Tools.
  4. Click Reset All.

NOTE: If Reset All is not available, follow the steps under method 2 to rename the Normal template.

Method 2: Rename the Normal Template

Use the appropriate method for your operating system.

Windows 95:

  1. Quit Word by clicking Exit on the File menu.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type Normal.dot and click C: (or the drive on which Word is installed) in the Look In list.
  4. Click Find Now.
  5. Rename any copies of Normal.dot. To do this, click to select the file name and then click Rename on the File menu. Type the new name of the file (such as Normal.old or Customer Name.dot) and press ENTER.
  6. Click OK if you receive a message that the file may become unusable.

Windows 3.x for Word 6.x:

  1. Start File Manager.
  2. Click on the disk drive that contains Microsoft Word.
  3. On the File menu, click Search.
  4. In the Search For box, enter Normal.dot and then click OK.
  5. Click to select the file, and then click Rename on the File menu.
  6. In the To box, type in a new name (such as Normal.old or Customer.dot)and then click OK.

About the Normal.dot File

The Normal.dot file is the "blueprint" (template) for Word documents. Word cannot run without a Normal template and automatically re-creates a new Normal template if it cannot find an existing one. After renaming Normal.dot, you can use the Organizer to copy custom styles, toolbars, autotext and macros to your new Normal.dot.

For additional information about how to use the Organizer, please see the following article in the Microsoft Knowledge Base:

169870 WD: Customizing and Sharing Toolbars In Microsoft Word


Or, see the appropriate sources below for your version of Word.

Word 97 for Windows:

Click the Office Assistant, type "Organizer," click Search, click "Use settings from another document or template," and then click the "Copy styles, AutoText entries, toolbars, or macros to a template" topic.

NOTE: If the Assistant is hidden, click the Office Assistant button on the Standard toolbar. If Microsoft Help is not installed on your computer, please see the following article in the Microsoft Knowledge Base:

120802 Office: How to Add/Remove a Single Office Program or Component


Microsoft Word 7.x:

  1. On the Help menu, click Answer Wizard.
  2. Under #1, type organizer and then click Search.
  3. Under #2, select "Copy styles, AutoText entries, toolbars, or macros to a template," and then click Display.

Microsoft Word 6.x:

  1. On the Help menu, click Search For Help On.
  2. Type organizer.
  3. Click to select Organizer and then click Show Topics.
  4. Click to select "Copying styles from a document or template" and then click Go To.

About Macro Viruses

For more information on Word macro viruses please see the following articles in the Microsoft Knowledge Base:

163932 Frequently Asked Questions About Word Macro Viruses


49500 List of Antivirus Software Vendors



Additional query words: 8.0 8.00

Keywords: kbhowto kbui KB173504