Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/173321

From BetaArchive Wiki

Article ID: 173321

Article Last Modified on 10/22/2000



APPLIES TO

  • Microsoft Excel 97 Standard Edition



This article was previously published under Q173321

SYMPTOMS

When you open a file in Microsoft Excel 97, you may receive the following error message:

'C:\Program Files\Microsoft Office\Office\Library\Msquery\Xlquery.xla' could not be found. Check the spelling of the file name, and verify that the file location is correct.

If you are trying to open the file from your list of most recently used files on the File menu, make sure that the file has not been renamed, moved, or deleted.

CAUSE

This error message occurs when you do the following steps:

  1. You move the Xlquery.xla file from its original folder to another folder.
  2. You open a file that contains a macro referencing the Xlquery.xla add-in.


STATUS

Microsoft has confirmed this to be a problem in Microsoft Excel 97 for Windows. This problem no longer occurs in Microsoft Excel 2000.

WORKAROUND

To work around this problem, use the following methods.

Method 1: Select the Xlquery.xla Add-In

  1. In Excel, click Add-Ins on the Tools menu.
  2. Click to select the MS Query add-in check box.

NOTE: If the MS Query add-in is not listed, click Browse to search for the Xlquery.xla file. This file is located in the following folder by default:

C:\Program Files\Microsoft Office\Office\Library\MSQuery


If you still receive the error message described in the "Symptoms" section of this article, or you cannot find the Xlquery.xla file, then go on to method 2.

Method 2: Move the Xlquery.xla Add-In to Its Original Location

  1. Click Start, point to Programs, and then click Windows Explorer.
  2. In Windows Explorer, point to Find on the Tools menu, and then click Files Or Folders.
  3. In the Named box, type Xlquery.xla.
  4. In the Look In list, click to select the disk drive that might contain the add-in file, and then click Find Now.
  5. If the search returns no files, repeat step 4 for any other disk drives that might contain the add-in file.
  6. When the search window returns the file, right-click the Xlquery.xla file icon, and then click Copy on the shortcut menu.
  7. In Windows Explorer, click to open the MSQuery folder. By default, this folder is located in:

    C:\Program Files\Microsoft Office\Office\Library\MSQuery

    NOTE: Depending on where you installed Excel, the MSQuery folder may be located in a different path.
  8. In Windows Explorer, click Paste on the Edit Menu.


MORE INFORMATION

Functions from the XLQuery.xla add-in that generate the error message include QueryGetData and QueryRefresh.


Additional query words: XL97

Keywords: kberrmsg kbprb KB173321