Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/170493

From BetaArchive Wiki

Article ID: 170493

Article Last Modified on 1/20/2007



APPLIES TO

  • Microsoft Access 97 Standard Edition



This article was previously published under Q170493

Moderate: Requires basic macro, coding, and interoperability skills.


SYMPTOMS

A replica that you have deleted or moved still appears in the Synchronize With list box when you select Replication on the Tools menu and then click Synchronize Now. The replica also appears in Replication Manager when you click All Replica Sites on the View menu.

CAUSE

Deleted or moved replicas are not automatically removed from the available list of replicas that can be synchronized.

RESOLUTION

If you want to remove a replica that no longer exists from the list of available replicas, follow these steps:

  1. On the Tools menu, click Replication, then click Synchronize Now.
  2. Select the replica in the Synchronize With list and click OK.
  3. Click OK in the message box that tells you that the replica can't be found.
  4. Click Yes in the message box that tells you Microsoft Access has deleted the replica and asks if you want to close and reopen the database now.


Note that in some cases the database does not close; however, the replica name is removed from the list. If this happens, click Cancel in the Synchronize Database dialog box to reset the database.


MORE INFORMATION

Steps to Reproduce Behavior


  1. Open the sample database Northwind.mdb.
  2. On the Tools menu, click Replication, and then click Create Replica.
  3. When the replica is created, note the folder to which Microsoft Access copies the replica.
  4. On the Tools menu, click Replication, and then click Synchronize Now. Note that the new replica appears in the list of replicas that you can synchronize with.
  5. Using Windows Explorer, find the replica and delete it from the folder.
  6. Return to Microsoft Access and on the Tools menu, click Replication, and then click Synchronize Now.


Note that the replica still appears in the list, and if you try to select it, you receive a message that Microsoft Access cannot find the replica.


REFERENCES

For more information about replication, search the Help Index for "replication manager, creating replicas."

Keywords: kbprb KB170493