Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/169658

From BetaArchive Wiki
Knowledge Base


Article ID: 169658

Article Last Modified on 1/19/2007



APPLIES TO

  • Microsoft Access 97 Standard Edition



This article was previously published under Q169658

Moderate: Requires basic macro, coding, and interoperability skills.


SYMPTOMS

When you run the Microsoft Access 97 Setup program from an administrative installation on a server, you may receive the following error message:

Setup Error 914
Object 27
Your Setup files may be damaged. Try restarting the Setup program from where you originally ran it.


You may also receive error messages regarding Objects 1932, 1933, 1934 and 3314. Finally, you receive the error message:

Microsoft Access 97 Setup was not completed successfully.

CAUSE

Microsoft Access 97 Setup is using a setup table (.stf) file that was opened, edited, and saved improperly in Microsoft Excel. The resulting corruption in the setup table can occur regardless of which version of Microsoft Excel you use to edit the file.

Also, if you open a custom .stf file in Microsoft Excel, make changes to it and save it, you may receive these error messages when you use the custom .stf file with Microsoft Access 97 Setup.

WORKAROUND

To prevent corruption of the setup table, you must perform extra steps immediately after opening the .stf file and prior to making any other changes to it.

  1. Open the .stf file. You can open the .stf file by following the steps in the following article in the Microsoft Knowledge Base:

    178330 How to install Access 97 wizards locally [Standalone network setup]


  2. After the .stf file is open, press CTRL+SHIFT+SPACEBAR to select the entire .stf file. Then, on the Data menu, point to Filter, and click AutoFilter.
  3. In cell E1, click the arrow, and then click the value "AddRegData."
  4. In cell F1, click the arrow and click Custom. In the Custom AutoFilter dialog box, set the following values

          Show rows where: F contains """" (four quotation marks)


    and click OK.

  5. Select all visible cells in column F. On the Edit menu, click Replace. In the Find What box, type a single space followed by a quotation mark ( "). In the Replace With box, type a quotation mark ("). Click Replace All.
  6. Select all visible cells in column F. On the Edit menu, click Replace. In the Find What box, type three quotation marks ("""). In the Replace With box, type two quotation marks (""). Click Replace All.
  7. Select all visible cells in column F. On the Edit menu, click Replace. In the Find What box, type two quotation marks (""). In the Replace With box, type a quotation mark ("). Click Replace All.
  8. On the Data menu, point to Filter, and click AutoFilter. Locate ObjID 27 in column A.
  9. Go to column G. Remove the leading space and the quotation marks surrounding the data in this cell.

You can now make changes to the .stf file. When you are finished, use the instructions shown in the Microsoft Knowledge Base article mentioned in step 1 and save the .stf file as a tab-delimited text file.

If you have already made changes to your .stf file and are receiving the error messages shown in the "Symptoms" section, you can repair your .stf file by following the steps in the "Workaround" section.

MORE INFORMATION

When you open an .stf in Microsoft Excel, the Text Import Wizard helps you convert the file (a very large text file) into a format that Microsoft Excel can display.

The steps used to open an .stf in earlier versions of Microsoft Access must be altered slightly to work correctly with the setup table files for Microsoft Access 97. Because of this, using the incorrect steps to open, edit, and save the setup table file will result in a corrupted setup table file, and you will receive the error messages shown in the "Symptoms" section when you run Microsoft Access 97 Setup.

REFERENCES

For more information about installing Microsoft Access 97 on a network, search the Help Index for "readme, Microsoft Access."

Keywords: kbprb kbsetup KB169658