Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/169277

From BetaArchive Wiki

Article ID: 169277

Article Last Modified on 1/19/2007



APPLIES TO

  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition



This article was previously published under Q169277

Novice: Requires knowledge of the user interface on single-user computers.


SYMPTOMS

If you output a report from Microsoft Access to another file format, such as .rtf, .txt, .xls, or .html, an OLE object that has been inserted into the report does not appear.

CAUSE

Although some output file formats, such as .rtf or .xls, do support embedded or linked OLE objects, Microsoft Access does not support outputting an OLE object to another file format.

RESOLUTION

If the OLE object has been saved separately, you can first output the report and then insert the OLE object in the resulting file.

MORE INFORMATION

Steps To Reproduce Behavior


  1. Open the sample database Northwind.mdb.
  2. Click the Reports tab, and then click the New button.
  3. In the New Report dialog box, click AutoReport: Tabular, in the "Choose the table or query where the object's data comes from" box, choose the Shippers table, and then click OK. The report opens in Preview mode.
  4. On the View menu, click Design View. Select the detail section of the report.
  5. On the Insert menu, click Object. In the Insert Object dialog box, select Microsoft Clip Gallery, and then click OK. Choose a picture and click the Insert button.
  6. On the View menu, click Print Preview. The picture appears in the detail section of the report.
  7. On the Tools menu, point to OfficeLinks, and then click Publish It With MS Word. If the Convert File dialog box appears, select Rich Text Format (RTF), and click OK. The report opens in Microsoft Word, but the OLE object does not appear.


REFERENCES

For more information about outputting data, search the Help Index for "OutputTo action," or ask the Microsoft Access 97 Office Assistant.

Keywords: kbinterop kbprb KB169277