Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/107461

From BetaArchive Wiki

Works for Windows 3.0: Contents of the MSWORKS3.TXT File

PSS ID Number: Q107461 Article last modified on 10-22-1998

3.00

WINDOWS

====================================================================== 3.00 WINDOWS kbprint

The information in this article applies to:
- Microsoft Works for Windows version 3.0

SUMMARY

The following is the complete contents of the MSWORKS3.TXT file for Microsoft Works for Windows, version 3.0.

=============================================================== MSWORKS3.TXT ===============================================================

This document contains information on the following:

  1. Opening or saving files - “Invalid SHARE parameters” message.
  2. Transferring files to the Macintosh.
  3. Using templates from a previous version of Works.
  4. Installing Works from a network.

(To view best on-screen in Windows Notepad, maximize the Notepad window and turn on wordwrap if it is not already on from the Edit menu, choose Word Wrap. For best printed results, open this document in Windows Write or Microsoft Works, select the entire document and format the text in 10 point Courier before printing.)

  1. “Invalid SHARE parameters” message when opening or saving files.

After installing Microsoft Works 3.0, it is sometimes necessary to turn off your computer and then turn it on again, so that special configuration changes can take effect. If you did not do this after installing Works, and you are getting the error message “Too many files open, or invalid SHARE parameters”, then try turning off your computer and restarting it.

  1. Using Macintosh PC Exchange to transfer your files to the Macintosh.

Microsoft Works for Windows can save files in Microsoft Works for Macintosh version 3.0 format. One way to move the files to a Macintosh is to use Macintosh PC Exchange. This allows your Macintosh to understand a MS-DOS or Windows floppy disk. For example, use the Save As command in Works for Windows, choose the “Works for Macintosh” option from the “Save File as Type” box, and save the file onto a 3.5" floppy diskette. Then, take this diskette and put it in your Macintosh.

With Macintosh PC Exchange, you will need to assign a document type to your files. Otherwise Works for Macintosh will not recognize the file. For instructions on how to assign document types, see the Macintosh PC Exchange User’s Guide. Below are the document types you need to assign so that Works for Macintosh can read files saved by Works for Windows.

Document Types:

Works for Windows uses a filename extension, or suffix, for files that are saved in Works for Macintosh format. Depending on the kind of document, when you save a Works for Windows file in Works for Macintosh format, the filename extension will be:

.WP for a Word Processor document .SS for a Spreadsheet .DB for a Database

Follow the directions in the Macintosh PC Exchange User’s Guide to assign the MS-DOS filename extension, or MS-DOS suffix, as follows:

MS-DOS Suffix Works for Macintosh document type

.WP AWWP .SS AWSS .DB AWDB

  1. Using templates from a previous version of Works.

Works for Windows version 2.0 and Works for MS-DOS version 2.0 or 3.0 templates can be opened in Works for Windows version 3.0. The template files for these previous versions of Works have special names. By specifying the special name in the File Open dialog box, you can open templates from one of these previous versions of Works in Works for Windows 3.0. The filenames for previous versions of Works are as follows:

Works for Windows 2.0 or Works for MS-DOS 3.0 Works for MS-DOS 2.0

TEMPLATE.1 TEMPLATE.PS TEMPLATE.2 TEMPLATE.KS . TEMPLATE.DB TEMPLATE.999

Look for these files in the Works program directory. (The subdirectory where you installed the previous version of Works.) If you do not know which directory this is, try looking in the subdirectory if your previous version was Works for Windows 2.0, or try if your previous version was Works for MS-DOS version 2.0 or 3.0.

One at a time, open these files in Works for Windows 3.0. Then choose the Save As command from the File menu to create a Works for Windows 3.0 template. For information on saving a template in Works for Windows 3.0, see the Microsoft Works User’s Guide.

After you have created Works for Windows 3.0 templates from the previous version’s files, you may want to delete the old files. You will not be losing data, because Works for Windows 3.0 makes a new copy of the file when it creates each template.

  1. Installing Works from a network.

If you are a network administrator and are installing Works for Windows 3.0 on a network, please read this section after reviewing the network installation instructions at the back of the User’s Guide.

After the administrator SETUP /A has been completed and you are ready to run setup for each workstation, you will need to adjust the working directory for each workstation:

Run SETUP for the workstation according to the User’s Guide instructions.

When the setup program is completed on the workstation, from Program Manager select the Microsoft Works icon and choose the Properties command from the File menu.

In the Working Directory box, type the drive and directory of the user directory for the workstation. For example, C:. Then choose the OK button. Repeat all steps for each workstation.

KBCategory: kbprint KBSubcategory: wworkskb Additional reference words: kbhowto 3.00 readme readme.txt text w_works ====================================================================== Version : 3.00 Platform : WINDOWS ============================================================================= Copyright Microsoft Corporation 1998.