Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/107148

From BetaArchive Wiki

Project Err Msg: “Cannot Start Publisher” with Edition File

PSS ID Number: Q107148 Article last modified on 11-14-1994

3.00

MACINTOSH

The information in this article applies to:
- Microsoft Project for the Macintosh, version 3.0 - Apple Macintosh operating system, versions 7.0, 7.0.1, 7.1

SUMMARY

In Microsoft Project, if you create an edition file by choosing the Create Publisher command from the Edit menu, if the edition file was published to a network server or public share that is no longer available, you will receive the following error message when you open the file

Cannot start publisher.

and the following message will be generated for any subscribers that are subscribing to the unavailable publisher:

Cannot start subscriber.

NOTE: You will get one message per publisher or subscriber that cannot be started. You must choose the OK button for each message in order to open the file.

WORKAROUNDS

There is no way to temporarily disable publishers or subscribers from being started while the network server or public share is unavailable. However, you can use one of the workarounds below to avoid having to go through each alert message every time you open the file.

Workaround 1

Before you try to reopen the files that reference the unavailable publisher(s), do the following:

  1. From the Apple menu, choose the Chooser command.
  2. In the Chooser verify that the network server or public share where the edition file(s) is located is an available server option.

As long as the server or the public share is available, you should not encounter the messages.

If the network server or public share no longer exists, or if the server or public share has changed its name or location, follow the steps in workaround 2 below.

Workaround 2

After you choose the OK button for each alert message you encounter and you open the files, delete any publisher or subscriber that references an unavailable edition file and recreate the publisher to an available server or folder location.

To remove or cancel a publisher:

  1. Open the file with the publishers that you want to remove.
  2. From the File menu, choose the Links command.
  3. From the Link Type list, choose the Publisher button.
  4. In the Links box, select each publisher that you want to remove; if there is more than one that you want to remove, select the first publisher, press and hold down the OPTION key, and select any additional publishers necessary.
  5. Choose the Options button.
  6. Choose the Cancel Publisher button; you will be prompted for each individual publisher that you selected to ensure you want to remove it. Choose the OK button then choose the Cancel Publisher button for that particular publisher.

To remove or cancel a Subscriber:

  1. Open the file with the subscribers that you want to remove.
  2. From the File menu, choose the Links command.
  3. From the Link Type list, choose the Subscribe button.
  4. In the Links box, select each subscriber that you want to remove; if there is more than one that you want to remove, select the first subscriber, press and hold down the OPTION key, and then select any additional subscribers necessary.
  5. Choose the Options button.
  6. Choose the Cancel Subscriber button; you will be prompted for each individual subscriber that you selected to ensure you want to remove it. Choose the OK button if you are sure. Then choose the Cancel Subscribers button for that particular subscriber.

For more information about publish and subscribe, see pages 629-634 of the version 3.0 “Microsoft Project User s Reference.”

KBCategory: kbusage KBSubcategory:

Additional reference words: macproj 3.00 7.00 7.01 7.10 mac software

Copyright Microsoft Corporation 1994.