Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/105114

From BetaArchive Wiki

BUG: Menu Bars with Skip For Option Cannot Be Reenabled

ID: Q105114

The information in this article applies to:

  • Microsoft FoxPro for Windows, versions 2.5x, 2.6x
  • Microsoft FoxPro for MS-DOS, versions 2.5x, 2.6x

SYMPTOMS

A SKIP FOR condition on an option on the menu pad will not reenable itself properly once it is disabled.

STATUS

Microsoft has confirmed this to be a problem in the products listed above. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

WORKAROUND

This problem only occurs when the menu pad uses the default system menu name.

For example, after following the instructions under "Steps to Reproduce Problem" in the next section of this article, perform the following to change the name of the "_msystem" menu pad:

1. From the Menu Level list box, select Menu Bar.

2. Select the Help prompt line, and then choose the Edit button.

3. From Menu (in the main FoxPro menu bar), choose "_msystem Options."

4. Generate the menu again.

MORE INFORMATION

Steps to Reproduce Problem

 1. Create a quick menu.

 2. On the quick menu File bar, change the Open prompt to read "x=.T.
    DISABLE" (without the quotation marks) with a result of COMMAND
    and "x=.T." (without the quotation marks).

 3. Change the Save prompt to read "x=.F. ENABLE" (without the
    quotation marks) with a result of COMMAND and "x=.F." (without the
    quotation marks).

 4. From the Menu menu, choose General Options. Under Menu Code,
    select Setup, and choose OK.

 5. In the Setup window, type "x=.F." (without the quotation marks),
    then close the window.

 6. On the quick menu Help (or System in FoxPro for MS-DOS) bar,
    select the Calculator option. Choose Options and then select the
    Skip For option. Type "x=.T." (without the quotation marks) in the
    Expression Builder window and choose OK.

 7. Generate your menu as TEST.

 8. In the Command window, issue the following command.

       DO test.mpr

    The Calculator will be enabled.

 9. From the File menu, choose x=.T. DISABLE.

    The Calculator will be disabled.

10. From the File menu, choose x=.F. ENABLE.

    The Calculator will not be reenabled.

11. In the Command window, type:

       x=.F.

The Calculator still will not be reenabled.

REFERENCES

"User's Guide," (Windows) page U12-15 "User's Guide," (MS-DOS) page U13-25

Additional reference words: FoxDos FoxWin 2.50 2.50a 2.50b 2.60 2.60a buglist2.50 buglist2.50a buglist2.50b buglist2.60 buglist2.60a re-enable KBCategory: kbtool kbprg kbbuglist KBSubcategory: FxtoolMbuilder


Last Reviewed: July 26, 1995
© 1999 Microsoft Corporation. All rights reserved. Terms of Use.