Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/104821

From BetaArchive Wiki

Mac Works: Import/Export Database to Paradox 4.0 for MS-DOS

PSS ID Number: Q104821 Article last modified on 10-22-1998

2.00 3.00

MACINTOSH

====================================================================== 2.00 3.00 MACINTOSH kbother kb3rdparty

The information in this article applies to:
- Microsoft Works for the Macintosh, versions 2.0 and 3.0

SUMMARY

To export Microsoft Works Database files to Paradox 4.0 for MS-DOS:

  1. Change the database from a tab-delimited to a comma-delimited database.
  2. Convert the data to an MS-DOS formatted disk.
  3. Import the file to Paradox.

These three steps are explained below.

STEP 1

To export Database files from Works 3.0 or 4.0 to a comma-delimited text file, do the following:

  1. Open the Database file in Works.

  2. From the File menu, choose Save As.

  3. Give the file a new name and choose Text as its format.

  4. Choose Save.

  5. Open the text-formatted database in the Word Processor by choosing Open from the File menu.

    1. Click the Word Processor icon.

    2. Locate the database on the hard drive using the scroll bar and click to select it.

    3. Choose Open.

  6. In Works version 3.0, the following message appears “There is no translator….” Choose OK. Works version 4.0 does not generate this message.

  7. From the Edit menu, choose Replace.

  8. Select the Find What box and click the Tab button (the one with the arrow pointing up).

  9. In the Replace With box, type a comma.

  10. Select Replace All.

  11. From the File menu, choose Save As.

  12. Rename the file with an MS-DOS filename and use a .TXT extension. (For example, DATABASE.TXT.) From the File menu, choose Format and select Text.

  13. Choose Save.

To export Database files from Works 2.0 to a comma delimited text file, do the following:

  1. Open the Database file in Works 2.0.

  2. From the File menu, choose Save As.

  3. Give the file a new name, and select Export and Save.

  4. Open the text-formatted database in the Word Processor by choosing Open from the File menu.

    1. Click the Word Processor icon.

    2. Click Import File.

    3. Click the file from the list.

    4. Choose Open.

  5. From the Search menu, choose Replace.

  6. Select the Find What box, click the Tab button (the one with the arrow pointing up).

  7. In the Replace With box, type a comma.

  8. Select Replace All.

  9. From the File menu, choose Save As.

  10. Rename the file with an MS-DOS filename and use a .TXT extension. (For example, DATABASE.TXT.) Click Export.

  11. Choose Save.

STEP 2

To load the database to an MS-DOS 3.5-inch formatted disk, follow these steps:

  1. Run Apple File Exchange, which can be found on the system disks if it’s not installed.
  2. Insert the MS-DOS formatted floppy disk.
  3. From the Mac-To-MS-DOS menu, choose Text Translation.
  4. In the Text translation Box, select Replace CR with CR/LF.
  5. Set Special Characters to Neither.
  6. Set Tab Character to Neither.
  7. Choose OK.
  8. Locate the database using the scroll bar and click to select it.
  9. Click the Translate button.
  10. When the translation is done, eject the disk by clicking the Eject button.
  11. From the File menu, choose Quit.

STEP 3

To import a Database into Paradox, do the following:

  1. Open Paradox.
  2. From the Tools menu, choose ExportImport.
  3. Select Import.
  4. From the ASCII menu, choose Delimited.
  5. In the Filename box, type the location and filename.
  6. Choose OK.
  7. Give the new Database a name in the Table field.

To import files from Paradox to Works, first export the file to a text file, load the file to a Macintosh through the Apple File Exchange, change the file from a comma-delimited file to a tab-delimited file, then import the file into the Works Database.

To export a Database from Paradox to a text file, follow these steps:

  1. Open the Paradox Database.
  2. From the Tools menu, choose ExportImport.
  3. Select Export.
  4. From the ASCII menu, choose Delimited.
  5. Under the Table dialog box, type the database name.
  6. In the Name box, type the location and name of the new database, for example, A:DATABASE.TXT.
  7. Choose OK.

To load the database to the Mac through Apple File Exchange, follow these steps:

  1. Run Apple File Exchange, which can be found on the system disks if it’s not installed.
  2. Insert the MS-DOS formatted floppy disk containing the database.
  3. From the MS-DOS-To-MAC menu, choose Text Translation.
  4. In the Text Translation box, select Replace CR/LF with CR.
  5. Set Special Characters to Neither.
  6. Set Tab Character to Neither.
  7. Choose OK.
  8. Locate the database on the floppy disk using the scroll bar and click the file to select it.
  9. Open or create a folder in which to hold the database.
  10. Click the Translate button.
  11. When the translation is done, eject the disk by clicking the Eject button.
  12. From the File menu, choose Quit.

To change the database from a Paradox comma-delimited file to a Works 3.0 tab-delimited file and open it in the Database module, do the following:

  1. Run Works.

  2. Choose the Word Processor icon.

  3. Click the file from the list.

  4. Choose Open.

  5. The message “There is no translator…” appears. Choose OK.

  6. Under the Edit menu, choose Replace.

  7. Select the Find What box, type a comma.

  8. In the Replace With box, click the Tab radio button (the one with the arrow pointing up).

  9. Select Replace All.

  10. To remove the quotation marks, choose Replace from the Edit menu.

    1. Select the Find What box, and type a " (single quotation mark).

    2. Leave the Replace With box blank.

    3. Select Replace All.

  11. From the File menu, choose Save As.

  12. Select Text from the File Format box.

  13. Give the file a new name.

  14. Choose Save.

  15. From the File menu, choose Open.

  16. Click the Database icon.

  17. Locate the new database and select it.

  18. Choose Open.

To change the database from a Paradox comma-delimited file to a Works 2.0 tab-delimited file and open it into the Database module, do the following:

  1. Run Works.

  2. Click the Word Processor icon.

  3. Locate the database on the hard drive using the scroll bar and click to select it.

  4. Click Import and select Open.

  5. The message “There is no translator…” appears. Choose OK.

  6. From the Search menu, choose Replace.

  7. Select the Find What box and type a comma.

  8. In the Replace With box, click the Tab radio button (the one with the arrow pointing up).

  9. Select Replace All.

  10. To remove the quotation marks, select Replace from the Edit menu.

    1. Select the Find What box, and type a " (single quotation mark).

    2. Leave the Replace With box blank.

    3. Select Replace All.

  11. From the File menu, choose Save As.

  12. Select Export.

  13. Give the file a new name.

  14. Click Save.

  15. From the File menu, choose Open.

  16. Click the Database icon and select Import.

  17. Locate the new database and select it.

  18. Click Open.

MORE INFORMATION

For more information, see pages 605-608 of the “Microsoft Works User’s Guide” for version 4.0, pages 433-436 of the “Microsoft Works User’s Guide” for version 3.0, pages 590-600 of the Paradox manual, “The User’s Guide,” and pages 256-260 of the System manual, “Macintosh User’s Guide.”

KBCategory: kbother kb3rdparty KBSubcategory: macworkskb

Additional reference words: mwksdb mwkswp paradox AFE import ms-dos dos export

====================================================================== Version : 2.00 3.00 Platform : MACINTOSH ============================================================================= Copyright Microsoft Corporation 1998.