Microsoft KB Archive/104806

From BetaArchive Wiki

Mac Works: Import/Export Database to FileMaker Pro

PSS ID Number: Q104806 Article last modified on 10-22-1998

2.0 3.0 4.0

MACINTOSH

======================================================================

The information in this article applies to:

  • == Microsoft Works for the Macintosh, versions 2.0, 3.0, and 4.0 ==

SUMMARY

This article discusses exporting and importing Database files between Works for the Macintosh and FileMaker Pro.

EXPORTING FILES FROM WORKS TO FILEMAKER PRO

To export Microsoft Works Database files to FileMaker Pro for the Macintosh, first save the document to a text file, then import the file into FileMaker Pro.

For Works 3.0 and 4.0

To export Database files from Works 3.0 or 4.0 to a text file, do the following:

  1. Open the Database file in Works 3.0.
  2. Form the File menu, choose Save As.
  3. Rename the file, choose File Format, and select Text.
  4. Choose Save.

For Works 2.0

To export Database files from Works 2.0 to a text file, do the following:

  1. Open the Database file in Works 2.0.
  2. From the File menu, choose Save As.
  3. Rename the file and select Export File.
  4. Choose Save.

To import Works Database text files into FileMaker Pro, do the following:

  1. Open FileMaker Pro and create a Database with the same field names as the Works Database.
  2. In Browse, choose Import/Export from the File menu and select Import Records.
  3. From the File Type list, choose Tab-Separated Text.
  4. Select the name of the Works Database.
  5. Click Open.
  6. Select Add New Records.
  7. Click OK.

IMPORTING FILES FROM FILEMAKER PRO TO WORKS

To import files from FileMaker Pro to Works, first export the file to a text file, then import the file into Works.

To export the Database to a tab-delimited text file, follow these steps:

  1. Open the FileMaker Pro Database.
  2. In Browse, choose Import/Export from the File menu and select Export Records.
  3. Type the name for the destination file and specify the location.
  4. Choose Tab-Separated Text from File Type.
  5. Click New.
  6. Select Don’t Format Output.
  7. Click OK.

To import the database to Works 3.0 or 4.0, follow these steps:

  1. Open Works (or if Works is open, choose Open from the File menu).
  2. Click the Database icon once.
  3. Locate the database on the hard drive using the scroll bar and click to select it.
  4. Click Open.
  5. Works version 3.0 only will prompt with “There is no translator available…” Click OK.
  6. Works will prompt with the “Separate Database Fields by:” message. Select Tabs. Click OK.

To import the database to Works 2.0, follow these steps:

  1. Open Works, or if Works is open, choose Open from the File menu.
  2. Click the Database icon once.
  3. Click Import File.
  4. Locate the Database on the hard drive using the scroll bar and click to select it.
  5. Click Open.
  6. Works will prompt with “There is no translator available…” Click OK.
  7. Works will prompt with the “Separate Database Fields by:” Select Tabs. Click OK.

FileMaker Pro is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product’s performance or reliability.

REFERENCES

“Microsoft Works User’s Guide,” for version 4.0, pages 605-608

“Microsoft Works User’s Guide,” for version 3.0, pages 433-436

“Using Microsoft Works,” for version 2.0, pages 397-408

Claris “FileMaker Pro User’s Guide,” pages 8-3, 8-16

Additional query words: 2.00 3.00 mac mwksconv 3rdparty file maker

====================================================================== Version : 2.0 3.0 4.0 Platform : MACINTOSH Issue type : kbhowto ============================================================================= Copyright Microsoft Corporation 1998.