Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/104695

From BetaArchive Wiki

XL3/XL4: How the Current Mode of Calculation Is Determined



The information in this article applies to:


  • Microsoft Excel for Windows, versions 3.x, 4.x
  • Microsoft Excel for the Macintosh, versions 3.x, 4.x





SUMMARY

In Microsoft Excel versions 3.x and 4.x, all currently open documents, except add-in macro sheets, use the same mode of calculation, regardless of the mode in which they have been saved.



MORE INFORMATION

To help explain how the mode of calculation is determined, this article refers to the following hypothetical documents:


                                               Saved with this
   Filename      Type of document              mode of calculation
   ---------------------------------------------------------------

   AUTO1.XLS     Worksheet                     Automatic
   MANUAL1.XLS   Worksheet                     Manual
   AUTO1.XLM     Macro sheet                   Automatic
   ADDIN.XLA     Add-in macro sheet            Automatic
   WORKBOOK.XLW  Multisheet Workbook           Automatic 



The following statements apply to calculation modes in Microsoft Excel:


  1. The first document you open uses the calculation mode with which it was last saved: subsequently opened documents use this same mode.


For example, if you first open AUTO1.XLS and then open MANUAL1.XLS, both documents will use automatic calculation (the mode used by AUTO1.XLS). If you open MANUAL1.XLS first and then open AUTO1.XLS, both documents will use manual calculation.

  1. Changing the calculation mode of one open document changes the mode for all open documents.


If AUTO1.XLS and AUTO1.XLM are both open, changing the calculation mode of AUTO1.XLM to manual also changes the mode of AUTO1.XLS to manual.

  1. All sheets contained in a workbook use the same mode of calculation.


If WORKBOOK.XLW contains a worksheet and a macro sheet, changing the calculation mode of the worksheet to manual also changes the macro sheet's calculation mode to manual.

  1. If all other documents are closed and you create a new document, the new document will use the same calculation mode as the previously closed documents. However, if you use a template, the mode of calculation will be the mode specified in the template.
  2. Add-in macro sheets do not affect the calculation mode of other documents.


If ADDIN.XLA is open and has its calculation mode set to automatic, opening MANUAL1.XLS will switch the calculation mode to manual, even though an automatic document (ADDIN.XLA) is already open.

The exception to this rule applies if the add-in appears in the Unhide dialog box (to unhide a document, press the SHIFT key and choose Open from the File menu), in which case the add-in follows the same rules as other types of documents.

Controlling the Mode of Calculation

Because open documents all use the same mode of calculation, you will need to follow special procedures when you want to work with documents that use different calculation modes. For example, if you are working with AUTO1.XLS and you want to open MANUAL1.XLS in manual calculation mode, do either of the following:


  • Set AUTO1.XLS to manual calculation mode before you open MANUAL1.XLS


-or-

  • Close AUTO1.XLS (and any other open documents) before you open MANUAL1.XLS

There are three modes of calculation in Microsoft Excel: automatic, automatic except tables, and manual.


   For this mode          Recalculation Occurs When
   -------------------------------------------------------------------

   Automatic              Any change is made to the document. All
                          affected parts of the document are
                          recalculated.

   Automatic              Any change is made to the document. All
   except tables          affected parts of the document EXCEPT TABLES
                          are recalculated. A table is recalculated
                          only when a change is made to it.

   Manual                 You specifically force recalculation. 




Recalculating the Active Document

To recalculate the active document:


  • Press SHIFT+F9 (all versions of Microsoft Excel)


-or-

  • Press COMMAND+SHIFT+= (Macintosh only)


-or-

  • Select the Calc Document option in the Calculation dialog box (Microsoft Excel 4.0 only)

Recalculating All Open Documents

To recalculate all open documents, do any of the following:


  • Press F9 (all versions of Microsoft Excel)


-or-

  • Press CTRL+= (Windows and OS/2 only)


-or-

  • Press COMMAND+= (Macintosh only)


-or-

  • From the Options menu, choose Calculate Now (Microsoft Excel 3.0 only)


-or-

  • Choose the Calc Now button in the Calculation dialog box (Microsoft Excel 4.0 only)

Changing the Mode of Calculation

To change the mode of calculation, follow these steps:


  1. On the Options menu, click Calculation.
  2. In the Calculation section of the dialog box, select the desired calculation mode (automatic, automatic except tables, or manual).



REFERENCES

"User's Guide 1," version 4.0, pages 167-174, 565
"User's Guide," version 3.0 for Windows and OS/2, pages 38-40
"User's Guide," version 3.0 for Macintosh, pages 33-35

Additional query words: 3.00 4.00 4.00a XL3 XL4

Keywords :
Version : WINDOWS:3.0,4.0; MACINTOSH:3.0,4.0
Platform : MACINTOSH WINDOWS
Issue type : kbinfo
Technology :


Last Reviewed: April 7, 1999
© 2000 Microsoft Corporation. All rights reserved. Terms of Use.