Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/103796

From BetaArchive Wiki

Mac Works: Import/Export FoxPro Databases

PSS ID Number: Q103796 Article last modified on 10-22-1998

2.0 2.5 2.5b 3.0 4.0

MACINTOSH

======================================================================

The information in this article applies to:

  • Microsoft Works for the Macintosh, versions 2.0, 3.0 and 4.0
  • Microsoft FoxPro for Windows, version 2.5
  • Microsoft FoxPro for MS-DOS, version 2.5
  • == Microsoft FoxPro for the Macintosh, version 2.5b ==

SUMMARY

To export a Works file to FoxPro, save the document to a text file, load the file to an MS-DOS-formatted floppy disk by using Apple File Exchange (AFE), then import the file into FoxPro. This article explains this procedure.

MORE INFORMATION

Saving Database Files in Works 3.0 as Text Files

To save Database files in Works 3.0 or 4.0 as text files, follow these steps:

  1. Open the Database file in Works 3.0 or 4.0.
  2. From the File menu, choose Save As.
  3. Give the file a new name, then click File Format and select Text.
  4. Click Save.

Saving Database Files in Works 2.0 as Text Files

To save Database files in Works 2.0 as text files, follow these steps:

  1. Open the Database file in Works 2.0.
  2. From the File menu, choose Save As.
  3. Give the file a new name, then click Export File.
  4. Click Save.

Copying the Database File to a Disk

To copy the Database file to an MS-DOS 3.5-inch formatted disk, follow these steps:

  1. Start Apple File exchange by clicking it. Apple File Exchange can be found on the system disks if it’s not installed.
  2. Insert the MS-DOS-formatted floppy disk.
  3. From the Mac To MS-DOS menu, choose Default Translation.
  4. Locate the file on the hard drive and click once to select it.
  5. Click the Translate button.
  6. When the translation is done, eject the disk by clicking the Eject button.
  7. From the File menu, choose Quit.

Importing a Database File in to FoxPro

To import a Database file in to FoxPro, follow these steps:

  1. Create a new database heading in FoxPro by choosing New from the File menu, and inserting the field names.
  2. From the Database menu, choose Append From.
  3. Click From and select the database.
  4. In the File Type box, select Delimited With Tabs.
  5. Click Append.

Importing Files from FoxPro to Works

To import files from FoxPro to Works, first save the file as a text file, load the file to a Macintosh by using Apple File Exchange, then import the file into Works.

To save the Database file to a tab-delimited text file, follow these steps:

  1. Open the Database in FoxPro.
  2. From the Database menu, choose Copy To.
  3. Type the name and location of the new exported database.
  4. In the File Type box, select Delimited By Tabs.
  5. Choose OK.

To load the Database file to the Macintosh using Apple File Exchange, follow these steps:

  1. Start Apple File Exchange by clicking it. Apple File Exchange can be found on the system disks if it’s not installed.
  2. Insert the MS-DOS-formatted floppy disk containing the Database file.
  3. From the MS-DOS To Mac menu, choose Default Translation.
  4. Locate the file on the floppy disk drive and click once to select it.
  5. Open or create a folder to hold the Database file.
  6. Click the Translate button.
  7. When the translation is done, eject the disk by clicking the Eject button.
  8. From the File menu, choose Quit.

To import the Database file to Microsoft Works 3.0 or 4.0, follow these steps:

  1. Open Works by double-clicking the Works icon.
  2. Click the Database icon once.
  3. Locate the Database file on the hard drive by using the scroll bar.
  4. Click Open, or double-click the Database filename.
  5. Works will prompt you with the Separate Database Fields By dialog box. Select Tabs and click OK.

To import the Database file to Microsoft Works 2.0, follow these steps:

  1. Open Works by double-clicking the icon.
  2. Click the Database icon once.
  3. Click Import File.
  4. Locate the Database file on the hard drive by using the scroll bar.
  5. Click Open, or double-click the Database filename.
  6. Works will prompt you with the Separate Database Fields By dialog box. Select Tabs and choose OK.

KBCategory: kbother KBSubcategory: macworkskb

Additional reference words: Works 2.00 3.00 FoxPro mac mwksdb import export AFE ms-dos formatted

====================================================================== Version : 2.0 2.5 2.5b 3.0 4.0 Platform : MACINTOSH Issue type : kbhowto ============================================================================= Copyright Microsoft Corporation 1998.