Registrations are now open. Join us today!
There is still a lot of work to do on the wiki yet! More information about editing can be found here.
Already have an account?

Microsoft KB Archive/103759

From BetaArchive Wiki

Project: Merging MPX file Cause Duplicate Tasks

PSS ID Number: Q103759 Article last modified on 03-15-1995

3.00 3.00a | 3.00

WINDOWS | MACINTOSH

The information in this article applies to:
- Microsoft Project for Windows, versions 3.0, 3.0a - Microsoft Project for Macintosh, version 3.0

SYMPTOM

When you merge an .MPX file into a an already open file, additional tasks may be created that have the same unique ID number as the original tasks. This problem may occur when you open the same .MPX file two or more times and request that one .MPX file be merged with the currently open .MPX file.

CAUSE

This problem occurs when you open and merge .MPX files that have tasks with lower ID numbers than their predecessors (forward predecessors).

WORKAROUND

To work around this problem, do the following:

  1. From the Table menu, choose Define Tables. Select the Export table and choose the Edit button.
  2. Make sure the table includes the Unique ID number, Unique ID Predecessors, and Unique ID Successors fields.
  3. Make sure that you delete the Predecessors and Successors fields from the table.

When you open the .MPX file, you may receive an error message. You can ignore this message; the file is imported correctly. When you open the .MPX file a second time (to merge it), no error messages are displayed and the file merges correctly without creating additional tasks.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Project for Windows versions 3.0 and 3.0a. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Steps to Reproduce Problem

  1. Enter ten tasks, T1 through T10.
  2. Link tasks 2 and 10 so that T10 is the predecessor to T2.
  3. From the File menu, choose Save As. Type the name “TEST.MPX” (without the quotation marks) and choose the MPX format. Choose OK.
  4. From the File menu, choose Open. Select TEXT.MPX (the .MPX file created in step 3). Choose OK.
  5. From the File menu, open the same file a second time. Choose OK
  6. Choose Yes when you are prompted to merge TEST into TEST.

When the file is opened, instead of having 10 tasks, there are now 12 (tasks 3 and 4 have been duplicated); if you look at the Unique Id numbers, the new tasks, 11 and 12, have the SAME Unique ID number as tasks 3 and 4.

KBCategory: kbusage KBSubcategory:

Additional reference words: 3.00 3.00a

Copyright Microsoft Corporation 1995.