Microsoft KB Archive/101476

From BetaArchive Wiki

Publisher Setup Changes MS Graph's OLE Registration

Publisher Setup Changes MS Graph's OLE Registration

Q101476


------------------------------------------------------------
The information in this article applies to:

 - Microsoft Publisher version 2.0
------------------------------------------------------------

SYMPTOMS
========

The Setup program for Microsoft Publisher version 2.0 will change the
way Microsoft Graph is registered in the REG.DAT file. Specifically,
this change will cause the description for Microsoft Graph to change
from "Microsoft Graph" to "Graph" in any Insert Object dialog box.

CAUSE
=====

Publisher's Setup program makes several changes to the Windows system
files, including the REG.DAT file. The REG.DAT file, located in the
WINDOWS directory, is used for the registration of your Windows-based
applications that are capable of performing
object-linking-and-embedding (OLE). Prior to installing Publisher 2.0,
if you have Microsoft Graph installed on your system, it will be
registered as "Microsoft Graph." After installing Publisher 2.0, it
will be changed to "Graph."

STATUS
======

Microsoft has confirmed this to be a problem in Publisher version 2.0 for
Windows 3.1. This problem was corrected in Windows 95.

SOLUTION
========

Note: This change will not affect the way Microsoft Graph works, only
the way it is started (that is, select Graph rather than Microsoft
Graph from the Insert Object dialog box).

The following seven-step procedure describes how to return Microsoft
Graph to its original registration in the REG.DAT file:

1. From the File Menu in Program Manager, choose Run.

2. In the Command Line box, type "regedit" (without the quotation
   marks) and choose OK. This will open a session of the Registration
   Info Editor.

3. Choose Graph from the Registered File Types list and then choose
   Modify File Types from the Edit Menu.

4. In the Modify File Type dialog box, change the File Type Description
   to read "Microsoft Graph" (without the quotation marks). Choose OK.

5. Choose Exit from the Registration Info Editor's File menu.

6. Open Write and choose Insert Object from the Edit menu.

7. The Object Type list box will now list Microsoft Graph.

MORE INFORMATION
================

Steps to Reproduce Behavior
---------------------------

1. Install any Windows-based application that ships with Microsoft
   Graph (for example, PowerPoint 3.0 or Word 2.0).

2. Open Write (located in the Accessories group by default) and choose
   Insert Object from the Edit menu.

3. The Object Type list box will list Microsoft Graph.

4. Close Write and install Microsoft Publisher version 2.0.

5. Open Write and choose Insert Object from the Edit menu.

6. The Object Type list box will now list Graph.

Additional query words: 2.00 mspub intl