Windows NT 4.0 Server instalation fails in 86box

Discuss Windows 2000, NT, XP and Windows Server 2000, 2003, SBS 2003.
Post Reply
Darthron2005
Posts: 4
Joined: Fri Jun 30, 2023 12:25 pm

Windows NT 4.0 Server instalation fails in 86box

Post by Darthron2005 »

I'm currently trying to install Windows NT 4.0 Server in 86box but it always fails after after copying the System Files, saying that Setup cannot set the required Windows NT configuration information and that it indicates an intrernal Setup error. Has anyone encountered this error before?
Image

86box config:
[*]86box 4.1.1 [build5634]
[*]Machine Type: Slot1
[*]Machine: [i440BX] AOpen AX6BC
[*]CPU Type: Pentium II (Deshutes)
[*]Speed: 333
[*]Memory: 256MB
[*]Video: [PCI] S3 Trio64 (Diamond Stealth64)
[*]Mouse: Standard PS/2 Mouse
[*]Sound card:None
[*]Network mode:PCAP
[*]Network Adapter: [PCI] AMD PCnet-FAST III
[*]HD Controller: Internal controller
[*]FD Controller: Internal controller
[*]80GB IDE dynamic VHD IDE Hard Drive on channel 0.0, ATAPI 8x CD-Rom Drive on channel 0.1

TheCollector1988
User avatar
Donator
Posts: 3605
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: Windows NT 4.0 Server instalation fails in 86box

Post by TheCollector1988 »

Why 80GB IDE...

PCMaster
Posts: 29
Joined: Tue Apr 18, 2023 3:27 pm
Location: Russia

Re: Windows NT 4.0 Server instalation fails in 86box

Post by PCMaster »

Darthron2005 wrote:
Wed May 15, 2024 4:44 pm
I'm currently trying to install Windows NT 4.0 Server in 86box but it always fails after after copying the System Files, saying that Setup cannot set the required Windows NT configuration information and that it indicates an intrernal Setup error. Has anyone encountered this error before?
Image

86box config:
[*]86box 4.1.1 [build5634]
[*]Machine Type: Slot1
[*]Machine: [i440BX] AOpen AX6BC
[*]CPU Type: Pentium II (Deshutes)
[*]Speed: 333
[*]Memory: 256MB
[*]Video: [PCI] S3 Trio64 (Diamond Stealth64)
[*]Mouse: Standard PS/2 Mouse
[*]Sound card:None
[*]Network mode:PCAP
[*]Network Adapter: [PCI] AMD PCnet-FAST III
[*]HD Controller: Internal controller
[*]FD Controller: Internal controller
[*]80GB IDE dynamic VHD IDE Hard Drive on channel 0.0, ATAPI 8x CD-Rom Drive on channel 0.1
That's because of a hard disk size limit (well I think so), you can't install it when it's more than 8 GB! Try to make a partition with 8 GB size, or try to make a new one with the same size!

Darthron2005
Posts: 4
Joined: Fri Jun 30, 2023 12:25 pm

Re: Windows NT 4.0 Server instalation fails in 86box

Post by Darthron2005 »

The partition I created during setup is 4GB, which worked fine on a physical Pentium 4 system with the same Hard Drive size. I think either the Bios or 86box have a Issue with 80GB drives as after switching the vhd for a 20GB one it stopped throwing that error

Post Reply