VMWare and VBEMP issues with NT 3.51 Server

Discuss Windows 2000, NT, XP and Windows Server 2000, 2003, SBS 2003.
Post Reply
Shintaro1969
User avatar
Posts: 31
Joined: Sat Jan 01, 2022 10:23 am

VMWare and VBEMP issues with NT 3.51 Server

Post by Shintaro1969 »

Hi,

I have been trying to get the VBEMP video driver working with NT 3.51 but it doesn't seem to work.
VMWARE 16.2.4 build-20089737
Host: Arch Linux

Guest: NT 3.51 Server
RAM: 64 Mb
Storage: 1Gb SCSI
VMWare 5.x profile

Installed 3.51 -> SP5
expand d:\i386\framebuf.dl_ c:\winnt35\framebuf.dll

Driver: AnaPa Corp VBE Miniport 1024x768 256 color

(copied vbemp.cpl to vbemp.sys)
CPL (2007) Stop 35

VBE2.0 (2007) Kmode exception not handled
VBE3.0(2007) Display looks like it is in 16 color mode (Couldn't change it)

VBE2.0 (2008) Kmode exception not handled
VBE3.0(2008) Display looks like it is in 16 color mode (Couldn't change it)

VBE2.0(2010) Kmode exception not handled
VBE3.0 (2010) Display looks like it is in 16 color mode (Couldn't change it)

I even, tried a complete re-install, making sure that I created a VMware 5.x profile first and 2010 VBE2.0, KMODE_EXCEPTION_NOT_HANDLED

I did see the other thread:viewtopic.php?p=413362&hilit=vmware+3.51#p413362

Any ideas?

Ironically works first time on VirtualBox.

Regards,
Craig
“Wyrd bið ful āræd. Fate is inexorable.”

vlad557776
FTP Access
Posts: 192
Joined: Sun Apr 28, 2019 10:11 am

Re: VMWare and VBEMP issues with NT 3.51 Server

Post by vlad557776 »

I never had good experience with VBEMP. Tried OS/2 Museum's VGA miniport driver? While the author specifies it was tested on VBox the driver should be generic enough for it to work on most modern video cards on NT OSes to around W10.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

TheCollector1988
User avatar
Donator
Posts: 3587
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: VMWare and VBEMP issues with NT 3.51 Server

Post by TheCollector1988 »

the OS/2 Museum VGA miniport is not generic as it relies on Bochs VBE's ports for it work properly and VMware doesn't emulate them.

Post Reply