New forum image uploader, no more imageshack!

Information and news about the website will be posted here.
Locked
Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

New forum image uploader, no more imageshack!

Post by Andy »

Ive created a small script so you can upload your images and screenshots to this site instead of imageshack.

http://www.betaarchive.co.uk/imageupload.php

The link is there or in the middle of the 5 at the top of the page.

It is very simple to use and provides the BBCode for you to copy and paste into your post. You only get one chance at copying it down though, once you close the page you will have to re-upload it again to get a new BBCode.

I hope this solves problems with imageshack etc not working or being slow.

Andy (Admin)

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

OOPS! Having issues with it on most images you upload, my test image worked fine for some reason. Im trying to fix it now, hold on!

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

Its now working! Ive been tearing my hair out over this and I don't know what was wrong! I used the same 3 scripts over and over and eventually got it working. Hurrah!

Enjoy its use and please please please tell me if you get an error message!

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

UPDATE:

Bug fixes:

- Added space-to-underscore replacement
- Added pjpeg MIME-type for Internet Explorer
- Added x-png MIME-type for Internet Explorer

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

More Updates:

- Added error message when submitting with no file selected instead of php error messages.
- Added a thumbnail of the image you uploaded on the upload page.

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

Bug fix:

- Filenames with brackets and exotic characters in them cause phpbb not to display the link>image, just the image. Prevented this by removing the original filename from the new one.

Old image syntax: UnixTime.Type.OriginalFilename
New image syntax: UnixTime.Type.RandomNumber.Extension

Andy
User avatar
Administrator
Posts: 12622
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

Ive updated the imageuploader so you can set the image quality! A long awaited feature.

As Ive just modified this you may get errors, if so, let me know ASAP and Ill get it fixed.

Locked