Having trouble with cd rom drivers in 86 box

Discuss any beta and abandonware applications.
Post Reply
Mister RoyFoy1
Posts: 77
Joined: Fri Jun 03, 2016 9:29 pm

Having trouble with cd rom drivers in 86 box

Post by Mister RoyFoy1 »

Alright so I'm trying to install dos 6 in 86 box (to later install Chicago) and I got dos to work but I can't access the cd rom. I tried auto detect but it didn't recognize anything. I then tried the windows 95 boot disk to see if its drivers worked but alas, they didn't. I don't know what to do now.

Machine: AMI winbios 486
CPU: intel i486SX/16
Memory: 4 MB
Display: [ISA] VGA
Floppy: 3.5" 1.44M
CD-ROM: ATAPI, channel-1:0, Speed 8x
Last edited by Mister RoyFoy1 on Fri Jun 07, 2019 8:09 pm, edited 1 time in total.

tarquin44
Posts: 55
Joined: Wed May 22, 2019 3:36 pm

Re: Having trouble with cd rom drivers in 86 box

Post by tarquin44 »

Try: CD-ROM: ATAPI, channel-0:1, Speed 8x,

I have Chicago 58 running in PCem, not tried it in 86box yet.

TheCollector1988
User avatar
Donator
Posts: 3544
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by TheCollector1988 »

What build of Chicago?
Also, Chicago builds before 99 don't have 32-bit support in esdi_506.pdr for ATAPI CD-ROM's, and you might want to use SCSI for such builds (either Adaptec 154x or Buslogic ISA/VLB/PCI).
tarquin44 wrote:Try: CD-ROM: ATAPI, channel-0:1, Speed 8x,

I have Chicago 58 running in PCem, not tried it in 86box yet.
Well, Secondary Master (1:0) is recommended in most cases, but not Primary Slave (0:1).

Mister RoyFoy1
Posts: 77
Joined: Fri Jun 03, 2016 9:29 pm

Re: Having trouble with cd rom drivers in 86 box

Post by Mister RoyFoy1 »

TheCollector1988 wrote:What build of Chicago?
Also, Chicago builds before 99 don't have 32-bit support in esdi_506.pdr for ATAPI CD-ROM's, and you might want to use SCSI for such builds (either Adaptec 154x or Buslogic ISA/VLB/PCI).
tarquin44 wrote:Try: CD-ROM: ATAPI, channel-0:1, Speed 8x,

I have Chicago 58 running in PCem, not tried it in 86box yet.
Well, Secondary Master (1:0) is recommended in most cases, but not Primary Slave (0:1).
58s. I'll try the adaptec 154x and the buslogic on ms dos 6

Edit: I tried them, didn't work. Also for some reason I can't boot to DOS anymore (maybe cause a tampered with the bios addresses with the scsi adapters? I don't know) even though it still has dos installed on it. Also the hard disk address changed from 9 to 47

TheCollector1988
User avatar
Donator
Posts: 3544
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by TheCollector1988 »

You don't set the CHS geometry on the CMOS for SCSI as it gets handled by its own bios (which you need to have and enable).
For the CMOS, set the CHS to none if you're using SCSI as the hdd, otherwise leave it unchanged, but set the CD-ROM to use SCSI (through the Aha154x, for CD-ROM the scsi bios is not needed).
And SCSI HDD's have different MBR (Master Boot Record) iirc than IDE HDDs from CMOS, if it is really the case, reinstall DOS from scratch.

Mister RoyFoy1
Posts: 77
Joined: Fri Jun 03, 2016 9:29 pm

Re: Having trouble with cd rom drivers in 86 box

Post by Mister RoyFoy1 »

TheCollector1988 wrote:You don't set the CHS geometry on the CMOS for SCSI as it gets handled by its own bios (which you need to have and enable).
For the CMOS, set the CHS to none if you're using SCSI as the hdd, otherwise leave it unchanged, but set the CD-ROM to use SCSI (through the Aha154x, for CD-ROM the scsi bios is not needed).
And SCSI HDD's have different MBR (Master Boot Record) iirc than IDE HDDs from CMOS, if it is really the case, reinstall DOS from scratch.
Are we talking about the same thing here? Cause when I mentioned the scsi configuration it had things like bios addresses, IRQ, Host ID, and DMA channel. I can't really find anything related to CHS geometry there

TheCollector1988
User avatar
Donator
Posts: 3544
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by TheCollector1988 »

The CHS geometry you had enabled was in the CMOS/BIOS of the machine, which should be disabled if you're using SCSI for the first hard disk (ID 0) too, unless you have it on another ID past 1.

MCpillager12
User avatar
Posts: 361
Joined: Wed Apr 17, 2019 12:44 pm
Location: Russia
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by MCpillager12 »

I have Chicago 58s working in 86box with following specs:
Machine: Intel Premiere/PCI II
CPU: Pentium 75
Memory: 16MB
Display: Tseng et4000ax
Floppy: 3.5" 1.44MB
CD-ROM: ATAPI; Primary slave; 2x
I first installed Dos 6.22, then installed this driver, then ran dossetup from CD.
Help!!!! hOw DO I run WiNdoWS 8 vM wIThouT vm soFtWarE???

ToMi1
User avatar
Posts: 55
Joined: Wed May 15, 2019 2:40 pm
Location: Czech Republic

Re: Having trouble with cd rom drivers in 86 box

Post by ToMi1 »

MCpillager12 wrote:I have Chicago 58s working in 86box with following specs:
Machine: Intel Premiere/PCI II
CPU: Pentium 75
Memory: 16MB
Display: Tseng et4000ax
Floppy: 3.5" 1.44MB
CD-ROM: ATAPI; Primary slave; 2x
I first installed Dos 6.22, then installed this driver, then ran dossetup from CD.
Where I can download the Tseng ET4000 driver?
Intel Core 2 Duo P8400 @ 2.26GHz, NVIDIA GeForce 9300M GS, 4GB DDR2 Memory, ADATA SU900 SSD (1TB), Windows 10 Enterprise 2019 LTSC x64

TheCollector1988
User avatar
Donator
Posts: 3544
Joined: Wed Feb 23, 2011 12:11 am
Location: Italy
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by TheCollector1988 »

You can use 58s' built-in et4000ax driver, which allows up to 1024x768x8bpp or 800x600x16bpp or 640x480x24bpp.

MCpillager12
User avatar
Posts: 361
Joined: Wed Apr 17, 2019 12:44 pm
Location: Russia
Contact:

Re: Having trouble with cd rom drivers in 86 box

Post by MCpillager12 »

ToMi1 wrote:
MCpillager12 wrote:I have Chicago 58s working in 86box with following specs:
Machine: Intel Premiere/PCI II
CPU: Pentium 75
Memory: 16MB
Display: Tseng et4000ax
Floppy: 3.5" 1.44MB
CD-ROM: ATAPI; Primary slave; 2x
I first installed Dos 6.22, then installed this driver, then ran dossetup from CD.
Where I can download the Tseng ET4000 driver?
It already has the driver built-in.
Help!!!! hOw DO I run WiNdoWS 8 vM wIThouT vm soFtWarE???

Post Reply