BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 11d, 16h, 42m | CPU: 10% | MEM: 5217MB of 11441MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 7 posts ] 
Author Message
 PostPost subject: Windows CE 5.0 Emulator        Posted: Sat May 27, 2017 2:47 am 
Reply with quote
Hello everyone.

I just discovered this neat piece of software: https://www.microsoft.com/en-us/downloa ... x?id=18481 .

It is a WinCE 5.0 device emulator preinstalled with a working emulator image. I've tested it myself on Windows XP (SP3), 7 (SP1), 8.1, and 10 (November and Anniversary updates). On XP and 7, the emulator can access the internet-- but for some reason, on 8 and newer, the emulator cannot.

Anyways, hope this helps anybody that's interested in WinCE emulation.

Offtopic Comment
Any ideas on how to get the internet access working on Win8 and newer?


Top
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Fri Sep 29, 2017 12:50 pm 
Reply with quote
Offline

Joined
Wed Sep 27, 2017 5:28 pm

Posts
65

Favourite OS
Win XP and Vista
Step 1:
-Load up the emulator (either through Device Emulator Manager or just hitting Ctrl-F5 from Visual Studio)
-Select File -> Configure
-Go to the Network tab
-Check the box that says "Enable NE2000 PCMIA network adapater and bind to:" (you can just use 'Connected network card' as it will automatically use your PC's ethernet card)
-You will get an error if you do not have Microsoft Virtual PC installed
-Click OK to close the dialog
-Select File -> Reset -> Soft (you must do this!)

Step 2:
-Open the emulator's Start Menu, select Settings
-Click on the Connections tab at the bottom
-Click on the Network Cards icon
-Change the combo box from "Work" to "The Internet"
-Click on OK (top right corner)

If still dont works, install Microsoft Virtual PC (Search internet how to install Microsoft Virtual PC on Windows 8 before installing because it cant install on Windows 8 or newer)

(Taked from https://social.msdn.microsoft.com/Forum ... tdeviceemu)

If it dont works, im sorry! :(


Top  Profile
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Fri Sep 29, 2017 9:22 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Tue Jun 09, 2015 4:02 am

Posts
254

Location
C:\WINDOWS\System32

Favourite OS
All under 2428
You never said it didn't work with x64 systems P=
I downloaded and it said it doesn't work with 64-bit WinOSes
Image
Compatibility mode doesn't work either

_________________
Windows :beta: Collector

Image

png is better than jpeg.


Top  Profile
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Sat Sep 30, 2017 8:20 am 
Reply with quote
Offline

Joined
Wed Sep 27, 2017 5:28 pm

Posts
65

Favourite OS
Win XP and Vista
WindowsCollector2000 wrote:
You never said it didn't work with x64 systems P=
I downloaded and it said it doesn't work with 64-bit WinOSes
Image
Compatibility mode doesn't work either


I never used this emulator.There is so many emulators for Windows CE 5.0 and, i taked solution from internet.So, i dont know it works or dont works on 64-bit operating systems...


Top  Profile
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Mon Oct 16, 2017 5:56 pm 
Reply with quote
FTP Access
Offline

Joined
Tue Oct 18, 2016 7:03 pm

Posts
92

Location
/home/thedosprogrammer

Favourite OS
MS-DOS 6.22
Emulator works perfectly in VM (I used Windows XP 32 bit in VirtualBox on 64 bit Windows 7) but it is very slow. But there is nothing interesting to see, there are only 4 apps preinstalled: Windows Explorer, Wordpad, Messenger (you have to sign in) and Internet Explorer.

_________________
Image


Top  Profile
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Fri Jan 25, 2019 12:16 am 
Reply with quote
Offline

Joined
Sun Aug 13, 2017 12:36 pm

Posts
5

Location
CH-VS

Favourite OS
Win7 SP1
Internet dosn't work ^^'
https://voxan.legtux.org/img/OM25ymOhgv.png


Top  Profile  WWW
 PostPost subject: Re: Windows CE 5.0 Emulator        Posted: Mon May 27, 2019 4:14 pm 
Reply with quote
FTP Access
Offline

Joined
Mon May 27, 2019 3:39 pm

Posts
14

Location
Second star to the right
The reason that it doesn't work is either that you don't have SLAT on your CPU or you are running it inside a VM (Hyper-V or Virtual PC). As The CE emulator and Microsoft virtualisation try and use the same config registers, the CE emulator will report that it cannot start as the system is already emulated.

If you are on a server version of Hyper-V, enabling nested virtualisation should allow you to run it. Otherwise find a First gen i7 or newer and run it on metal.


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 




Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2020

 

Sitemap | XML | RSS