Build 5112 Basic VS + Vista Beta 1 Style Logon (XP)

Discussions about *nix and Other Operating Systems should go in this forum.
Post Reply
Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Build 5112 Basic VS + Vista Beta 1 Style Logon (XP)

Post by Saarineames »

Since this is somewhat beta-related, I thought I would share these with anyone using Windows XP:

-- Build 5112 Basic Visual Style
-- Windows Vista Beta 1 Build 5112 Style logonui.exe

I made these for my final XP disc to replace the default luna theme and logonui.exe
with an updated UI that retains an authentic Windows look.

Aero basic from Vista Beta 1 has always been a favorite of mine, and a logical replacement, so I went about it!
These are as close to the real deal (within limitations and differences) as I could get. Pretty happy with the turnout!

Some screenshots:

Image

Image

Download links:

Build 5112 Basic Visual Style for Windows XP

Windows Vista Beta 1 Build 5112 Style logonui for Windows XP

Genuine wallpapers, Segoe UI fonts, Styler Toolbar, and Start button bitmaps are included.
Please refer to the readme file before applying the style about some light prep for swapping
out the explorer.exe bitmaps for the (dynamic) start button.
Supports Normal, Large & Extra Large fonts, and 32x/48px icons.
Two shellstyles to choose from: Basic (left vertical task pane 'Beta 1 Control Panel' style')
and Basic 2 (bottom horizontal task pane) seen in the screenshot.

The logon background will adjust to all resolutions, as it is a dynamic
gradient, and not an image. Full button effects (mousefocused, keyfocused/selected).

Enjoy!

Saarineames

[Edit July 2] Updated VS download link and screenshot.
Last edited by Saarineames on Wed Jul 02, 2008 7:53 pm, edited 1 time in total.

Bender
User avatar
Donator
Posts: 1524
Joined: Fri Aug 18, 2006 4:30 pm

Post by Bender »

Does this need a patched UXTheme.dll?
Image
Mozilla/5.0 (Macintosh; U; PPC; en-US; mimic; rv:9.3.2) Clecko/20120101 Classilla/CFM
"Stupid can opener! You killed my father, and now you've come back for me!"

Rob Jansen
User avatar
Donator
Posts: 5271
Joined: Sat May 12, 2007 1:05 pm
Location: The Collection Book
Contact:

Post by Rob Jansen »

With Nlite there is an option to patch the UXTheme.dll at installation.

But after installation you can just the the UXTheme patcher.

Luckie
User avatar
Donator
Posts: 1115
Joined: Thu Aug 24, 2006 8:03 am
Location: Germany

Post by Luckie »

This is nice Thanks for making this although I'm no longer using XP, but I've also patched the imageres.dll to have the old Login Screen from Beta1 inside the Final Vista. I love this blue
"Theory is when you know something, but it doesn't work. Practice is when something works, but you don't know why. Programmers combine theory and practice: Nothing works and they don't know why."

asX

Post by asX »

Nice work!, thx

Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Post by Saarineames »

Right on, dudes. Glad you like 'em!

Bender -- yes, you'll need to patch the uxtheme.dll.

I always do it (when not using an nlited source) the old-fashioned way -- download the patched file, and then swap it out with Replacer.

Ignore these links if not needed:

uxtheme patch

Replacer

Luckie -- Cool! I dual-boot XP & Vista, but I would like to do a complete port of Beta 1 over to Final when the right .msstyles editor is released, if possible.

Luckie
User avatar
Donator
Posts: 1115
Joined: Thu Aug 24, 2006 8:03 am
Location: Germany

Post by Luckie »

Saarineames wrote:I would like to do a complete port of Beta 1 over to Final when the right .msstyles editor is released, if possible.
wait for the release of AveStyle
"Theory is when you know something, but it doesn't work. Practice is when something works, but you don't know why. Programmers combine theory and practice: Nothing works and they don't know why."

Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Post by Saarineames »

Yes, that's the one I'm waiting on... Now that I think about it, a port of 5219 or 5231 would be better. We'll see. Focus on original stuff, too.

Ensign Joe
FTP Access
Posts: 175
Joined: Sun Apr 06, 2008 6:22 pm
Location: Germany

Post by Ensign Joe »

It's not working, I replaced the start menu flag with the white one (which looks pretty good on Royale Noir as well) and then I try to use that theme (patched uxtheme) and the preview window shows some weird windows without title bars, the Advanced options window does not appear and applying it fails with an "Unknown Error".
Image

Also I can't activate the Welcome Screen. If i tick the checkbox and press OK and go to that menu again the checkbox is empty...

Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Post by Saarineames »

Hmm. I've heard of people getting these errors when using an autopatcher for uxtheme files. Best bet would be to download the uxtheme file from the link in the post above and switch it out with replacer, then try applying the .msstyle again.

I set up XP in a virtual machine this morning, and I just tested it. All works fine here:

Image


As for the logon, same goes -- just swap it out with replacer.

Or, if you plan to use it temporarily...

Copy the logonui.exe file to C:\

Open up regedit and navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Look for the string "UIHost", double click it and change the path to C:\logonui.exe.

If you want to restore the default logon, just change the path back to logonui.exe and delete the logonui.exe file from C:\

Here's a quick way to do both:

Create a folder in My Documents called "ReplacerFiles" and copy the logonui.exe and the patched uxtheme.dll file into that folder.

Now create a .txt file inside the folder and call it "ReplacerScript".

Copy the text below into the .txt file, and save.
Now fire up replacer. Drop this text file into the window and follow the instructions. Hope that helps, let me know.

Copy between the lines
---------------------
;; ReplacerScript
logonui.exe
uxtheme.dll
---------------------

Ensign Joe
FTP Access
Posts: 175
Joined: Sun Apr 06, 2008 6:22 pm
Location: Germany

Post by Ensign Joe »

Well how do we say in German?
"Reboot tut gut"

After a restart, all worked fine

(well.. except for logonui)
Last edited by Ensign Joe on Sun Jun 15, 2008 6:10 pm, edited 1 time in total.

Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Post by Saarineames »

Good to hear, Joe!

Ensign Joe
FTP Access
Posts: 175
Joined: Sun Apr 06, 2008 6:22 pm
Location: Germany

Post by Ensign Joe »

Well, was my fault.
When I configured this PC i set the "Always use classic Log in" in gpedit.
This is why the settings weren't applied.
(Windows could have told me this...)

Now it (should) work(s)



Wuhu! It's working


How did you get those Longhorn icons as well? (On your screen shots)

Saarineames
User avatar
FTP Access
Posts: 125
Joined: Tue Jun 10, 2008 8:55 pm

Post by Saarineames »

^ Those icons are the real deal, only modified (256x256 compressed pngs removed) for XP. I'll can send them to you, if you like.

Ensign Joe
FTP Access
Posts: 175
Joined: Sun Apr 06, 2008 6:22 pm
Location: Germany

Post by Ensign Joe »

Saarineames wrote:^ Those icons are the real deal, only modified (256x256 compressed pngs removed) for XP. I'll can send them to you, if you like.
Oh that would be great

Post Reply