BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 35d, 15h, 27m | CPU: 26% | MEM: 5877MB of 12287MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 PostPost subject: IBM OS/2 Warp 4 inside Bochs        Posted: Sat May 27, 2017 12:19 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Thu Apr 09, 2015 2:54 pm

Posts
66

Location
Tula, Russia

Favourite OS
5.1.2600
Has anybody tried to run IBM OS/2 Warp 4 in the Bochs? I was able to run 1.3, 2.11 and even Warp 3, but when I try to install Warp 4 I get TRAP 000D after loading diskette 2.

_________________
My Longhorn Site


Top  Profile  WWW
 PostPost subject: Re: IBM OS/2 Warp 4 inside Bochs        Posted: Sun Sep 24, 2017 4:51 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Mar 16, 2014 6:56 am

Posts
152

Favourite OS
DOS
I got the same problem (Bochs 2.6.8 on Linux). I tried setting "cpu: cpuid_limit_winnt=1", I tried disabling USB (which I'd enabled even though it's not the default, since I'd used it before) and also disabling PCI and none of that helped.

I tried Bochs 2.6.9 though and it didn't fail at that point, and I was able to do a fairly standard install successfully. During and after the install it didn't seem to start up reliably, hanging at the splash screen, but normally a reset or two seems to be all that is required. I'm not sure, but I have a feeling that tapping the shift keys and/or moving the Bochs window while it's starting up helps, or maybe it's random and I just didn't do enough testing to work out what is going on.

Here are the "interesting" (non-default, important, or I played with them at some point during this process) parts of the configuration, which was based on the sample from Bochs 2.6.8:

Code:
cpu: model=pentium, count=1, ips=50000000, reset_on_triple_fault=1, [...]
cpu: cpuid_limit_winnt=0
memory: guest=32, host=256
vga: extension=none, update_freq=20, realtime=1
pci: enabled=1, chipset=i440fx
clock: sync=both, time0=local
floppya: 1_44=[...], status=inserted
ata0: enabled=1, [...]
ata1: enabled=0, [...]
ata0-master: type=disk, path=[...].img, [...]
ata0-slave: type=cdrom, path=[...].iso, status=inserted


For what it's worth, I have an old installation I did previously under Bochs - judging by my bochsout.txt I think I probably did it under a CVS build of Bochs 2.1.1 running on Windows XP in the year 2004 (https://sourceforge.net/p/bochs/discuss ... /929f0ec3/ (the first Google search result I found) says something about needing to use a CVS build of 2.1.1 to install Warp 4 at that time, and bochsout.txt shows that that's what I used, although I can't guarantee that's what I used for the install). This install runs fine under Bochs 2.6.8 as far as I can tell, so I guess the issue in Bochs 2.6.8 only affected the installation of Warp 4, not running it.


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 




Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2019

 

Sitemap | XML | RSS