BetaArchive Logo
Navigation Home Screenshots Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 23d, 19h, 15m | CPU: 32% | MEM: 5612MB of 12227MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 3 posts ] 
Author Message
 PostPost subject: WINE install probs, linux n00b needs help. Bad.        Posted: Sat Nov 24, 2007 6:55 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Hey, i got this error while installing wine



!!! All ebuilds that could satisfy "media-libs/libgphoto2" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/libgphoto2-2.3.1-r2 (masked by: corruption)
- media-libs/libgphoto2-2.3.1-r3 (masked by: corruption)
- media-libs/libgphoto2-2.3.1-r4 (masked by: corruption)
- media-libs/libgphoto2-2.4.0-r1 (masked by: corruption)
- media-libs/libgphoto2-2.3.1-r5 (masked by: corruption)
- media-libs/libgphoto2-2.2.1-r1 (masked by: corruption)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "media-gfx/sane-backends-1.0.18-r5" [ebuild])

Remember:i'm a real linux n00b. If i ask silly questions, please excuse me.

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
 PostPost subject:        Posted: Sat Nov 24, 2007 7:33 pm 
Reply with quote
Donator
Offline

Joined
Sat Sep 30, 2006 5:00 pm

Posts
3557
That means one of the items WINE needs to function can't be compiled because the ebuild is corrupt. I'd not try to unmask it but wait a day or some more, perform an "emerge --sync" and try again.

And, sorry if that sounds harsh, but a Gentoo-based distro is not the way to go for "a real linux n00b", to quote you. Gentoo is meant for people that do know their way around Linux and know how to fix the system if something goes wrong and it is, yes, probably one of the "hardest" distros around. If I may give an advice, switch to Ubuntu 7.10 which is targeted at beginners and advanced users equally. It'll save you much time and hassle if you're a beginner. You'll get Compiz-Fusion and all that jazz as well, and you'll probably have less problems installing packages via apt than via Portage.

Remember: Gentoo (and Sabayon due to being Gentoo-based) are targeted at the experienced Linux user. If you want to stay with it, then I'd highly recommend you read at least http://gentoo-wiki.com/HOWTO_Use_Portage_Correctly before you start screwing around with the system, otherwise it can be a very frustrating experience. On Gentoo, it's important that you know what you're doing, typing some commands without knowing what they do is a very bad idea, especially if you're root.

BTW, you could have discussed the problem in the other thread :)


Top  Profile
 PostPost subject:        Posted: Sun Nov 25, 2007 1:52 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Ok, i did --sync again (today, a day after) but now i get this message

!! Error: the <sys-fs/udev-114 package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/h ... =1#blocked

Then i did --pretend and

Calculating dependencies... done!
[ebuild N ] media-libs/libgphoto2-2.4.0-r1 USE="hal nls -doc -exif" CAMERAS="-adc65 -agfa_cl20 -aox -barbie -canon -casio_qv -clicksmart310 -digigr8 -digita -dimagev -dimera3500 -directory -enigma13 -fuji -gsmart300 -hp215 -iclick -jamcam -jd11 -kodak_dc120 -kodak_dc210 -kodak_dc240 -kodak_dc3200 -kodak_ez200 -konica -konica_qm150 -largan -lg_gsm -mars -mustek -panasonic_coolshot -panasonic_dc1000 -panasonic_dc1580 -panasonic_l859 -pccam300 -pccam600 -polaroid_pdc320 -polaroid_pdc640 -polaroid_pdc700 -ptp2 -ricoh -ricoh_g3 -samsung -sierra -sipix_blink -sipix_blink2 -sipix_web2 -smal -sonix -sony_dscf1 -sony_dscf55 -soundvision -spca50x -sq905 -stv0674 -stv0680 -sx330z -template -toshiba_pdrm11"
[ebuild N ] media-gfx/fontforge-20071110 USE="X nls python svg tiff unicode -gif -jpeg -png -truetype"
[ebuild N ] media-gfx/sane-backends-1.0.18-r5 USE="gphoto2 ipv6 usb v4l"
[ebuild N ] app-emulation/wine-0.9.49 USE="X alsa cups dbus esd hal jack ncurses opengl scanner -jpeg -lcms -ldap -nas -oss -xml"
[blocks B ] <sys-fs/udev-114 (is blocking media-libs/libgphoto2-2.4.0-r1, media-gfx/sane-backends-1.0.18-r5)

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2018

 

Sitemap | XML | RSS