BetaArchive
https://www.betaarchive.com/forum/

Mac OS X DP2 won't boot properly after installation
https://www.betaarchive.com/forum/viewtopic.php?f=65&t=40990
Page 1 of 1

Author:  os9er [ Tue Mar 24, 2020 11:48 pm ]
Post subject:  Mac OS X DP2 won't boot properly after installation

Hi all,

I'm new to this forum, but it seems like an appropriate place for this question I have... I have downloaded Mac OS X Developer Preview 2 from a different site, and have been attempting to install it on a PowerBook G3 Lombard. The issue I'm consistently running into is this: the installation will go smoothly, but after rebooting into the installed system, it hangs right before the Setup Assistant should be launched. The mouse cursor is still movable, but there's nothing else on the screen - just the blue background. If anyone has any pointers as to why this is happening, and/or whether there's a workaround, it would be greatly appreciated. Of course, I'm not going to use it regularly, but such alphas/betas are kind of fun to mess with.

Thanks,
-os9er

Author:  tarquin44 [ Wed Mar 25, 2020 1:59 pm ]
Post subject:  Re: Mac OS X DP2 won't boot properly after installation

If you're just wanting to run DP2 for fun, it installs and runs well in QEMU. I have it running in QEMU on Windows 10, if you want I can post the configuration.

Author:  DVINTHEHOUSEMAN [ Wed Mar 25, 2020 3:31 pm ]
Post subject:  Re: Mac OS X DP2 won't boot properly after installation

I think DP2 would only run on a beige g3 or an early blue and white.

Author:  os9er [ Wed Mar 25, 2020 9:15 pm ]
Post subject:  Re: Mac OS X DP2 won't boot properly after installation

Thanks for replying... The installation manual says it can run on any PowerBook G3 except the original 1997 model, so I figured I'd try it on my Lombard... As for QEMU, I have it installed on my PC, I just don't especially like having to start it via the command-line. However, if you could post your configuration @tarquin44, I'll try it.

Thanks,
-os9er

Author:  tarquin44 [ Thu Mar 26, 2020 2:52 pm ]
Post subject:  Re: Mac OS X DP2 won't boot properly after installation

Firstly you'll need to create a 2G drive with

qemu-img.exe create -f raw -o size=2G dp2.img

You then need to initiallise the disk in Mac OS9, (I used Mac OS 9.1 in QEMU). Then launch QEMU with:

qemu-system-ppc.exe -L pc-bios -boot d -m 512 -M g3beige -cpu g3 -prom-env "boot-device=cd:9,\\:tbxi" -prom-env "boot-args=-v" -prom-env "vga-ndrv?=true" -drive file=dp2.iso,format=raw,media=cdrom -drive file=dp2.img,format=raw,media=disk -sdl -netdev user,id=network01 -device sungem,netdev=network01

When it's finished installing shut down QEMU and boot into the hard disk with:

qemu-system-ppc.exe -L pc-bios -boot c -m 512 -M g3beige -cpu g3 -prom-env "auto-boot?=true" -prom-env "boot-args=-v" -prom-env "vga-ndrv?=true" -drive file=dp2.img,format=raw,media=disk -sdl -netdev user,id=network01 -device sungem,netdev=network01

That will do it.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/