BetaArchive
https://www.betaarchive.com/forum/

Windows CE 5.0 Emulator
https://www.betaarchive.com/forum/viewtopic.php?f=63&t=37166
Page 1 of 1

Author:  TuneableSumo876 [ Sat May 27, 2017 2:47 am ]
Post subject:  Windows CE 5.0 Emulator

Hello everyone.

I just discovered this neat piece of software: https://www.microsoft.com/en-us/downloa ... x?id=18481 .

It is a WinCE 5.0 device emulator preinstalled with a working emulator image. I've tested it myself on Windows XP (SP3), 7 (SP1), 8.1, and 10 (November and Anniversary updates). On XP and 7, the emulator can access the internet-- but for some reason, on 8 and newer, the emulator cannot.

Anyways, hope this helps anybody that's interested in WinCE emulation.

Offtopic Comment
Any ideas on how to get the internet access working on Win8 and newer?

Author:  Microsoft Windows Fan [ Fri Sep 29, 2017 12:50 pm ]
Post subject:  Re: Windows CE 5.0 Emulator

Step 1:
-Load up the emulator (either through Device Emulator Manager or just hitting Ctrl-F5 from Visual Studio)
-Select File -> Configure
-Go to the Network tab
-Check the box that says "Enable NE2000 PCMIA network adapater and bind to:" (you can just use 'Connected network card' as it will automatically use your PC's ethernet card)
-You will get an error if you do not have Microsoft Virtual PC installed
-Click OK to close the dialog
-Select File -> Reset -> Soft (you must do this!)

Step 2:
-Open the emulator's Start Menu, select Settings
-Click on the Connections tab at the bottom
-Click on the Network Cards icon
-Change the combo box from "Work" to "The Internet"
-Click on OK (top right corner)

If still dont works, install Microsoft Virtual PC (Search internet how to install Microsoft Virtual PC on Windows 8 before installing because it cant install on Windows 8 or newer)

(Taked from https://social.msdn.microsoft.com/Forum ... tdeviceemu)

If it dont works, im sorry! :(

Author:  WindowsCollector2000 [ Fri Sep 29, 2017 9:22 pm ]
Post subject:  Re: Windows CE 5.0 Emulator

You never said it didn't work with x64 systems P=
I downloaded and it said it doesn't work with 64-bit WinOSes
Image
Compatibility mode doesn't work either

Author:  Microsoft Windows Fan [ Sat Sep 30, 2017 8:20 am ]
Post subject:  Re: Windows CE 5.0 Emulator

WindowsCollector2000 wrote:
You never said it didn't work with x64 systems P=
I downloaded and it said it doesn't work with 64-bit WinOSes
Image
Compatibility mode doesn't work either


I never used this emulator.There is so many emulators for Windows CE 5.0 and, i taked solution from internet.So, i dont know it works or dont works on 64-bit operating systems...

Author:  TheDosProgrammer [ Mon Oct 16, 2017 5:56 pm ]
Post subject:  Re: Windows CE 5.0 Emulator

Emulator works perfectly in VM (I used Windows XP 32 bit in VirtualBox on 64 bit Windows 7) but it is very slow. But there is nothing interesting to see, there are only 4 apps preinstalled: Windows Explorer, Wordpad, Messenger (you have to sign in) and Internet Explorer.

Author:  voxan [ Fri Jan 25, 2019 12:16 am ]
Post subject:  Re: Windows CE 5.0 Emulator

Internet dosn't work ^^'
https://voxan.legtux.org/img/OM25ymOhgv.png

Author:  ContemporaryAwareness [ Mon May 27, 2019 4:14 pm ]
Post subject:  Re: Windows CE 5.0 Emulator

The reason that it doesn't work is either that you don't have SLAT on your CPU or you are running it inside a VM (Hyper-V or Virtual PC). As The CE emulator and Microsoft virtualisation try and use the same config registers, the CE emulator will report that it cannot start as the system is already emulated.

If you are on a server version of Hyper-V, enabling nested virtualisation should allow you to run it. Otherwise find a First gen i7 or newer and run it on metal.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/