BetaArchive Logo
Navigation Home Screenshots Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 7d, 20h, 32m | CPU: 44% | MEM: 2269MB of 4969MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 12 posts ] 
Author Message
 PostPost subject: I think I screwed up my USB Drivers.        Posted: Wed Sep 10, 2008 12:24 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Hey all,

So ya, i think i screwed up my USB Drivers. When i plug in a USB Device, it says that "This Device Can Perform Faster" but before it never said that. All my ports are USB 2.0 so i'm sure its the drivers.

Ok, so every time i start the computer, it says "Found new Hardware: USB 2.0 Root Hub"
If i let it search, it gives an error, if i close the window, it gives an error: "There was an error with the installation" etc.


So in my Device Manager, It has 2 USB Controllers categories:
Image

And also as you can see in the picture,
I have 5 drivers for the other category,
I tried to uninstall the one with the ! mark, but it always reappears.
PCI Class USB 2.0 Enhanced Host Controller (i tryed to uninstall it, but it always freezes the computer)
|--->Manufacturer: OWC
|--->Driver Provider: Unknown
|--->Driver Date: Not available
|--->Driver Version: Not available
|--->Digital Signer: Not Digitally Signed

Then 2x This:(USB Root Hub)
Image
Image

And 2x This:(Standard OpenHCD USB Host Controller)
Image
Image

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
 PostPost subject:        Posted: Wed Sep 10, 2008 1:40 am 
Reply with quote
Donator
User avatar
Offline

Joined
Fri Jun 13, 2008 10:22 am

Posts
2366
What version, including service pack, of Windows are you running?


Top  Profile
 PostPost subject:        Posted: Wed Sep 10, 2008 11:05 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Windows XP SP2
Build 2600.xpsp_sp2_qfe.070227-2300 (Service Pack 2)

However, when i downloaded my webcam drivers, i accidentally clicked USB 2.0 Driver install.
if you want to see the installer its in this package:
http://www.rocketfishproducts.com/skins/skin_1/Topics/Drivers/RF-Webcam.zip

I think thats what caused the problems.

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
 PostPost subject:        Posted: Thu Sep 11, 2008 5:50 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Fri Jun 13, 2008 10:22 am

Posts
2366
Try uninstalling everything from device manager under the "universal serial bus controllers" section, make sure everything USB is unplugged. NOTE: If your keyboard/mouse are USB they are going to stop working at this point, it's best to have a PS/2 mouse/keyboard. Then reboot your computer and let Windows reinstall the drivers. Once it has reinstalled all the USB drivers start plugging things back in. Let us know how it goes.


Top  Profile
 PostPost subject:        Posted: Fri Sep 12, 2008 12:06 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Ok, but when i try to uninstall the one called PCI Class USB 2.0 Enhanced Host Controller, Windows freezes.

Also, my mouse is a Touchpad, is that USB? (its a laptop).

An again, whenever Windows starts, it gives the "Found New Hardware" [censored] and the error. I just want to make sure, cause i don't want to end up without USB and having to re-install windows.

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
 PostPost subject:        Posted: Fri Sep 12, 2008 11:32 am 
Reply with quote
Donator
User avatar
Offline

Joined
Thu Aug 31, 2006 2:45 pm

Posts
1432

Location
UK

Favourite OS
Longhorn 4074
Dr Eggman wrote:
Also, my mouse is a Touchpad, is that USB? (its a laptop).

Most likely no, i think in most laptops it's connected with this:
Image
(whatever name it has)


Top  Profile  WWW
 PostPost subject:        Posted: Fri Sep 12, 2008 1:34 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Fri Jun 13, 2008 10:22 am

Posts
2366
If it freezes when you uninstall one of them chances are that your trackpad is USB, even if it doesn't have a standard USB cable. Can you still use your keyboard when it freezes? I'm pretty much out of suggestions. Try to do a repair install of Windows.


Top  Profile
 PostPost subject:        Posted: Fri Sep 12, 2008 7:59 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Fri Aug 18, 2006 4:30 pm

Posts
1520

Favourite OS
Mac OS 9.2.2
Dr Eggman wrote:
Ok, but when i try to uninstall the one called PCI Class USB 2.0 Enhanced Host Controller, Windows freezes.

Also, my mouse is a Touchpad, is that USB? (its a laptop).

An again, whenever Windows starts, it gives the "Found New Hardware" [censored] and the error. I just want to make sure, cause i don't want to end up without USB and having to re-install windows.
My laptop is a Dell Latitude D600, and Windows says that the touchpad is PS/2

_________________
Image
Mozilla/5.0 (Macintosh; U; PPC; en-US; mimic; rv:9.3.2) Clecko/20120101 Classilla/CFM
"Stupid can opener! You killed my father, and now you've come back for me!"


Top  Profile
 PostPost subject:        Posted: Sat Sep 13, 2008 1:57 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Windows says the touchpad is PS/2


Also, when i try to uninstall the driver, everything just stops. Mouse. Keyboard. Windows.

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
 PostPost subject:        Posted: Sat Sep 13, 2008 2:20 am 
Reply with quote
Donator
Offline

Joined
Fri Oct 26, 2007 5:12 pm

Posts
2461
Reinstall Windows? :/


Top  Profile
 PostPost subject:        Posted: Sat Sep 13, 2008 9:58 am 
Reply with quote
Donator
User avatar
Offline

Joined
Fri May 18, 2007 9:39 am

Posts
953

Location
My house
happy dude wrote:
Reinstall Windows? :/

Or even a simple Repair install.

_________________
Image


Top  Profile
 PostPost subject:        Posted: Sat Sep 13, 2008 5:35 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Jun 30, 2007 8:25 pm

Posts
321

Location
Eggmanland/Toronto

Favourite OS
Longhorn 4015.lab06
Well guys, did ALOT of screwing, with safe mode, and uninstalling, and now, in the end, hopefully, its solved. I uninstalled ALL the drivers, then hit search. So it should be ok. And its not popping up that "This device can perform faster" window any more. Yay!

_________________
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!


Top  Profile  WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 




Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2018

 

Sitemap | XML | RSS