BetaArchive
https://www.betaarchive.com/forum/

Windows 2000 Server Build 1964 in 86Box
https://www.betaarchive.com/forum/viewtopic.php?f=61&t=39919
Page 1 of 1

Author:  SupernovaNick [ Fri Jun 07, 2019 6:55 am ]
Post subject:  Windows 2000 Server Build 1964 in 86Box

I am trying to install Windows 2000 Server Beta 3 (build 1964) in 86Box. However, setup hangs at the "Setup is starting Windows 2000" part.
I cannot upgrade because WINNT32.EXE is missing from the CD-ROM image.

Does anyone else get this problem? Is there a fix for this?

Thanks.

Author:  TheCollector1988 [ Fri Jun 07, 2019 11:39 am ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

What emulated machine are you using? Configuration, nvr?

Author:  SupernovaNick [ Fri Jun 07, 2019 10:13 pm ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

Award 430VX PCI, Pentium 200, 128MB RAM, VLB Phoenix S3 Trio64, PS/2 Mouse, Sound Blaster 16

Author:  Microsoft Windows Fan [ Sat Jun 08, 2019 9:56 am ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

SupernovaNick wrote:
Award 430VX PCI, Pentium 200, 128MB RAM, VLB Phoenix S3 Trio64, PS/2 Mouse, Sound Blaster 16


It might be because of your host specs. You need a really powerful CPU (at least something like a not too old very high-end i5) to emulate 200 mhz without any slowdowns. Please send your host specs. In the meanwhile, please try a slower CPU (Like a Pentium 120 maybe).

Author:  TheCollector1988 [ Sat Jun 08, 2019 3:39 pm ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

Well, try using the Trio64 as a PCI card.

Author:  SupernovaNick [ Sun Jun 09, 2019 1:10 am ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

Microsoft Windows Fan wrote:
It might be because of your host specs. You need a really powerful CPU (at least something like a not too old very high-end i5) to emulate 200 mhz without any slowdowns.

But it is not that the machine is slow. I was able to install build 1965 just fine. Build 1964 just hangs at the “Setup is starting Windows 2000” for at least half an hour without any progress.

Microsoft Windows Fan wrote:
In the meanwhile, please try a slower CPU (Like a Pentium 120 maybe).

TheCollector1988 wrote:
Well, try using the Trio64 as a PCI card.

I will try these.
EDIT: Neither of these solutions work.

Author:  Microsoft Windows Fan [ Tue Jun 11, 2019 8:54 pm ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

SupernovaNick wrote:
I was able to install build 1965 just fine


Oh, you should've said that earlier. By the way, did you change the BIOS date to 1999-01-21 before? If you didn't, then please do it and try again. If you did, then maybe change the graphic card to an S3 Virge DX or try disabling Power Management from the BIOS. If they also don't work, just try a different VM software like VPC2007. You can get VPC2007 if you run XP, Vista or 7. If you run 8.x 32-bit/64-bit or 10 32-bit, you must do some extra steps to get VPC2007 (Just search for tutorials on the internet). Unfortunately though, on Windows 10 64-bit, you can't get VPC2007. Try VMware or Virtualbox if you have Windows 10 64-bit.

Author:  SupernovaNick [ Wed Jun 12, 2019 12:54 am ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

Microsoft Windows Fan wrote:
did you change the BIOS date to 1999-01-21 before?

Yes. I was aware that this build will give an error during the GUI part of the setup if the BIOS date is not 21 January, 1999, but I never heard anyone getting this problem due to an incorrect BIOS date, so I am pretty sure the BIOS date is not the problem here.
Offtopic Comment
Also, all Windows 2000 pre-release builds I have ever downloaded (from both BetaArchive and other websites) have no timebombs aside from the error during the GUI stage of setup in build 1964. All Windows 9x and Windows XP pre-release builds I have download have timebombs, but the Windows 2000 pre-release builds I have downloaded have their timebombs already disabled. I asked why they do when other Windows pre-release builds do not in this post: viewtopic.php?f=61&t=39916


Microsoft Windows Fan wrote:
maybe change the graphic card to an S3 Virge DX

Does not work.

Microsoft Windows Fan wrote:
try disabling Power Management from the BIOS.

Disabling both power management and PM control by APM does not work.

Microsoft Windows Fan wrote:
If they also don't work, just try a different VM software like VPC2007.

This is pretty strange, considering that 86Box runs software that most hypervisors cannot. I have never heard of something not working in emulators like 86Box or PCem that works in virtualization software like VPC, VirtualBox, and VMware.

Maybe I will try PCem or VMware. I was able to install 15xx build of Windows Codename Memphis in 86Box by installing them in VMware Workstation first and using WinImage to convert the .VMDKs to .IMGs so 86Box could run them (they experience errors in 86Box and PCem), as explained in this post: viewtopic.php?f=60&t=39847.

Author:  SupernovaNick [ Wed Jun 12, 2019 7:14 am ]
Post subject:  Re: Windows 2000 Server Build 1964 in 86Box

EDIT: VMware does not work, but I found a solution.

WINNT32.EXE does not exist on the CD image, but WINNT.EXE still does, allowing you to do an upgrade from MS-DOS. I used a Windows 98 boot disk to partition and format the drive and used WINNT.EXE and it now brings me to the first stage of setup.
:D

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/