BetaArchive Logo
Navigation Home Screenshots Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 0d, 5h, 24m | CPU: 30% | MEM: 1977MB of 2895MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 5 posts ] 
Author Message
 PostPost subject: Windows NT 3.1 service pack        Posted: Sat Dec 01, 2007 9:57 pm 
Reply with quote
Is there any way that you can check which service pack you're running in NT 3.1? In all other versions (3.5, etc) it shows it in the about box and also during the blue screen while starting, but NT 3.1 doesn't seem to do this.

I'm having some trouble with my NT 3.1 install where it will randomly (about 25% of the time) give a stop error on boot. Microsoft acknowledged this as a known issue and says that it's fixed in the latest service pack. I installed SP3 but the problem is still occuring. So, I don't know whether the SP3 install actually did work or not - maybe it failed and didn't tell me.


Top
 PostPost subject:        Posted: Sun Dec 02, 2007 9:45 am 
Reply with quote
Donator
Offline

Joined
Sat Sep 30, 2006 5:00 pm

Posts
3557
It should display the SP version in the places you mentioned. If it doesn't you can presumably always compare the version of NTOSKRNL in your system to that in SP3. If it's the same, the SP3 has at least been partially applied, if it's older, then you should maybe reinstall it.


Top  Profile
 PostPost subject:        Posted: Sun Dec 02, 2007 7:16 pm 
Reply with quote
Hmm, that's very strange then.

I checked the create date on ntoskrnl.exe and it's the same as the SP3 version. I've installed the SP a few times now and it's the same each time.

NT 3.1 just has one service pack, right? Not one for Advanced Server and another for the regular workstation? The only site on the whole internet that I managed to find the SP for download is this:

http://wiki.oldos.org/Downloads/OSUpdates

Even Microsoft's site is useless - they claim that you can download it by searching for "servpack", but when you do that, it doesn't find anything relevant.


Top
 PostPost subject:        Posted: Sun Dec 02, 2007 7:51 pm 
Reply with quote
Donator
Offline

Joined
Sat Sep 30, 2006 5:00 pm

Posts
3557
There's only one service pack for Workstation & Server variants, it's like this on every NT variant up to 5.1 (XP).

Another place to download NT 3.1 SP3 (US) is [url]ftp.gaby.de/pub/win3x/archive/softlib[/url], file names are SP3_31.EXE to SP3_39.EXE. That dir above is a mirror of the Microsoft Software Library from 1991 to 1994, BTW.


Top  Profile
 PostPost subject:        Posted: Mon Dec 03, 2007 4:38 am 
Reply with quote
I just did a fresh install of NT 3.1 Advanced Server (was previously using Workstation) and straight away installed SP3, and it still doesn't seem to show which service pack is installed anywhere.

This is what makes me think that it's possibly normal behaviour for it not to tell you - either that or both of my copies of NT 3.1 are corrupted somehow.


Top
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 




Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2018

 

Sitemap | XML | RSS